Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 09-10-2021, 07:35 PM
Sandman9200 Sandman9200 is offline
Learning to use the forums
 
Join Date: Feb 2019
Posts: 1
Default 97 2.3 lacks low-mid range power

Hey guys, first thread on this forum here but I have an interesting issue with my truck. I got a 1997 2.3L 2wd 5speed that I've dumped a ton of time and cash on it doing a budget "restoration" and she's up and running for the most part. The issue I have is that it feels like it has no power in the low-mid RPM range. Once it gets to about 3000 RPM at wide open throttle it works out of the low power and suddenly starts moving right along just fine kinda feels like it's got a Honda motor with vtec. It idles perfectly fine and feels like it has all power once it's up there in the RPM range. I've replaced plugs, wires, coils, timing belt/tensioner, o2 sensors. The IAC valve and EGR works as they should, no vacuum leaks, MAF is clean and reads correctly on a scan tool. I've read on a different post that the IAT sensor could be the issue because that reads much higher than ambient temperature, usually around 100-110 degrees. Very strange issue I've never run into before and I do have two other rangers with the 2.5L and 5 speed manual transmissions and those run like a top. This is my first truck with the 2.3l. I know that the 2.3s and 2.5s are virtually the exact same motor minus the minor increase in displacement and power. Just want to get some ideas and see what you guys think.
__________________
1997 Ford Ranger XLT 2.3L Extended Cab
1998 Ford Ranger XLT 2.5L
2000 Ford Ranger XLT 2.5L
2004 Jeep Wrangler Sport 4.0L
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
95 ranger 4cyl lacks power Mcdaniel Introduce Yourself 1 05-02-2013 09:36 PM
Hello to the range 91FR91XLT Introduce Yourself 5 12-07-2012 10:38 AM
94, 5 speed, 150k, lacks power Atomicthunk 4-Cylinder Tech 3 04-11-2012 12:01 PM
99 2.5l runs rough & lacks power 99ranger86 4-Cylinder Tech 2 04-04-2012 04:23 PM
92 2.3L Ranger runs leans and lacks power pad2383 4-Cylinder Tech 7 04-18-2010 07:27 PM