Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > Ford Ranger Semi-Technical > Wheels and Tires
Forgot Password? Join Us!


Reply
 
LinkBack Thread Tools Search this Thread

  #1  
Old 06-28-2011, 04:28 PM
Learning to use the forums
 
Join Date: Jun 2011
Posts: 5
Default 94 brake problem

Hey Guys, so I am having a problem with my brakes, the problem being that they appear to be sticking and getting so hot that they start to smoke. Its pulling to the right and I can definately tell that my truck is struggling to get up to speed.

This seems kinda serious to me and I am wondering if you guys think that it is the calipers? It is still the calipers that have the pins holding them on. I have looked at the pistons holding the pads on and they seem a bit chipped up.

I just changed the timing belt, and it is in time and everything was fine for a few weeks until this happened.

So how hard would this be to change myself if indeed it is the calipers.

Um if you guys need any more information that might help just ask. Thanks
Reply With Quote
  #2  
Old 06-28-2011, 04:30 PM
Mr. One Fitty
 
Join Date: Apr 2011
Posts: 16,681
Send a message via AIM to djfllmn
Default Re: 94 brake problem

calipers are pretty easy to do...x2 on them sticking
__________________
2014 F150 Supercrew XLT 5.0(ALL the options)
1968 Ford Thunderbird Tudor 429 Thunderjet V8

(Click for Project Log)
DD-1992 Olds Cutlass Ciera
traded-2007 F150 XLT Supercab 5.4
Sold:03 Sonic Blue FX4 Steppie 4.0SOHC 5spd

Quote:
Originally Posted by Logan03CO View Post
These threads make me feel better about myself....
Quote:
Originally Posted by guell View Post
Welcome to the internet, if this is your first visit to it I suggest you stock up on a lot of preparation h cause you gonna be butt hurt a lot
Reply With Quote
  #3  
Old 07-03-2011, 10:19 AM
Learning to use the forums
 
Join Date: Jun 2011
Posts: 5
Default Re: 94 brake problem

Just wanted to give an update, replaced the calipers and the rubber brake line, no problems bleeding them other than not realizing that air was getting sucked through the threads when using the vacuum pump. I power bled it after using the vacuum pump and the brakes are working great again.
Thanks.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with a brake problem ILuvMyRanger Drivetrain Tech 4 12-11-2012 05:14 AM
Weird brake problem. Puredreamz Drivetrain Tech 11 12-03-2010 06:54 PM
Rear brake problem Dan Woodland General Tech 1 10-25-2010 09:28 AM
E-brake problem 90fordranger General Tech 0 03-20-2010 01:08 PM
Rear Brake Problem let0927 General Tech 0 12-23-2009 05:07 PM



Search Engine Friendly URLs by vBSEO 3.6.0 ©2011, Crawlability, Inc.