Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #16  
Old 10-29-2010, 03:04 PM
Ranger01 Ranger01 is offline
Ford Ranger Driver
 
Join Date: Nov 2009
Posts: 2,402
Default Re: My new ride!

I am thinking it is the alternator. i started it up it ran for about 10 min. I putit in drive and it died and won't restart. I am gunna have the alternator tested
__________________
2001 3.0 V6 Automatic "Police Interceptor"
4x4 Off-Road
3" Body Lift
Belltech 6400 Shackles
JBA Headers
LOKRITE Locker
COBRA disc conversion
Reply With Quote
  #17  
Old 10-29-2010, 03:07 PM
2002 2WD Edge 2002 2WD Edge is offline
Ford Tough
 
Join Date: Mar 2010
Posts: 387
Default Re: My new ride!

Since the vehicle was neglected..including the oil..the previous owner probably never put injector cleaner in the gas. Try putting one of the heavy duty injector cleaners in the gas tank..and fill it up. There are the cheaper cleaners which are meant to be used frequently and the heavy duty (expensive unless you score one on sale) which are good for 3,000 miles. Usually a motor that needs an oil change runs noticeable better with new oil too.
__________________
JBA s.s. headers&exhaust, K&N cold air intake, Bosch Iridium Plus 4 plugs, Royal Purple in motor, 5spd & diff.,Superchips programmer, axle girdle. Also have but yet to install KYB Gas-A-Just shocks and Belltech sway bars.
Reply With Quote
  #18  
Old 10-29-2010, 03:11 PM
2002 2WD Edge 2002 2WD Edge is offline
Ford Tough
 
Join Date: Mar 2010
Posts: 387
Default Re: My new ride!

Quote:
Originally Posted by Ranger01 View Post
I am thinking it is the alternator. i started it up it ran for about 10 min. I putit in drive and it died and won't restart. I am gunna have the alternator tested
Maybe get the battery test too....easier to replace than an alternator.
__________________
JBA s.s. headers&exhaust, K&N cold air intake, Bosch Iridium Plus 4 plugs, Royal Purple in motor, 5spd & diff.,Superchips programmer, axle girdle. Also have but yet to install KYB Gas-A-Just shocks and Belltech sway bars.
Reply With Quote
  #19  
Old 10-29-2010, 03:14 PM
More_Cowbell More_Cowbell is offline
Chrome Dont Get You Home
 
Join Date: Dec 2009
Posts: 1,169
Default Re: My new ride!

Quote:
Originally Posted by 2002 2WD Edge View Post
Maybe get the battery test too....easier to replace than an alternator.
hell get both tested while your at it its free
__________________
1990 Ranger Extended Cab
2.9L V6 5 Speed Transmission
Planning to put a 347 and a T-5 in it eventually

Quote:
Originally Posted by FireRanger View Post
It looks like someone attacked the front of the truck with a bedazzler.
Reply With Quote
  #20  
Old 10-29-2010, 04:06 PM
GeorgiaRanger GeorgiaRanger is offline
Bronco!
 
Join Date: Dec 2009
Posts: 1,188
Default Re: My new ride!

I want OHC!
__________________
Bronco in the near future!

2002 Gold Ranger (46k miles) : Totaled May 2012

Quote:
Originally Posted by chaddwalters View Post
Lmao like a good neighbor, FRF is there!
Reply With Quote
  #21  
Old 10-29-2010, 04:10 PM
edgeman4.0 edgeman4.0 is offline
THE COMPLAINT DEPARTMENT
 
Join Date: Nov 2009
Posts: 3,962
Default Re: My new ride!

Quote:
Originally Posted by Fordzilla80 View Post
That truck looks brand new!

As far as the idle problem, sounds a bit like what my Ranger was doing. Played with the IAC yet?

My original IAC was overexerting itself, and couldn't hold a steady idle. It would eventually die if I didn't hold it at the correct idle manually. Dealer I bought the truck from let me swap the IAC for one from another 3.0 Ranger he had, and problem solved. Feel bad for the sucker that bought the other Ranger though.
x2 that should fix the issue.
__________________
2001 Ford Ranger Supercab (4dr), Oxford White, 4.0 Sohc, 4x4, Manual trans (hurst equipped), 4:10's, 3" body lift.
Quote:
Originally Posted by Demon-FX4 View Post
The Edgeman sees his prey and strikes out from the darkness.
Quote:
Originally Posted by Rango88 View Post
Dont f+ck with Ch+ck
Reply With Quote
  #22  
Old 10-30-2010, 05:44 PM
Ranger01 Ranger01 is offline
Ford Ranger Driver
 
Join Date: Nov 2009
Posts: 2,402
Default Re: My new ride!

Well figured out the problem. I'm a *******
__________________
2001 3.0 V6 Automatic "Police Interceptor"
4x4 Off-Road
3" Body Lift
Belltech 6400 Shackles
JBA Headers
LOKRITE Locker
COBRA disc conversion
Reply With Quote
  #23  
Old 10-31-2010, 09:50 AM
2002 2WD Edge 2002 2WD Edge is offline
Ford Tough
 
Join Date: Mar 2010
Posts: 387
Default Re: My new ride!

Quote:
Originally Posted by Ranger01 View Post
Well figured out the problem. I'm a *******
What was it?
__________________
JBA s.s. headers&exhaust, K&N cold air intake, Bosch Iridium Plus 4 plugs, Royal Purple in motor, 5spd & diff.,Superchips programmer, axle girdle. Also have but yet to install KYB Gas-A-Just shocks and Belltech sway bars.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
New ride.... Dcrymes99ranger Off Topic 22 08-16-2010 03:39 PM
New Ride..... mjonesjr Vehicle Snapshots 21 07-18-2010 08:46 PM
Went for a ride and took some pics. 99rangerguy Vehicle Snapshots 8 07-17-2010 06:27 PM
Got a new ride... for now Ranger01 Vehicle Snapshots 21 07-10-2010 01:53 PM
Took a ride 08xlt Vehicle Snapshots 4 02-27-2010 07:06 PM