Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-11-2011, 10:41 AM
Black04Ranger Black04Ranger is offline
New to Trucks...
 
Join Date: Mar 2010
Posts: 122
Default HUGE POTHOLE... broke something on suspension

Well there guys... just as the title says.... I hit a HUGE pothole today (with the driver's side front tire) on the highway going about 60mph because some A-Hole swung into my lane almost right into me, and I had to swerve to avoid an accident.

Well the pothole won, and something on my drivers side front suspension is broken.... it is making a "CLUNK" noise lots of times when I'm making a sharp turn or sometimes when I hit a bump in the road.

I think that I figured out what is broken, but I just wanted some expert FRF opinions!


I looked under the truck and what do I see....... well the damn sway bar no longer is attached to the top of the sway bar link!


Here is a pic of the driver's side swaybar and link... as you can see the top of the link is broken clean off!



Here is a pic of the passenger's side swaybar and link... the link is still connected as it should have been.



Here is a diagram of a ford ranger suspension..... I believe the link slides through a gaurd and is attached above the sway bar, and below the lower control arm.




Here is a link to the part I BELIEVE I need from Ebay, but can anybody confirm that this is the correct part? ALSO, if I order it, how do I go about putting the new one in place?
http://cgi.ebay.com/ebaymotors/ws/eB...K%3AMEWAX%3AIT



Lastly, is it safe to drive it home from work today like this? I have 30 miles to drive straight on the highway back to home. Is there any way I can ghetto rig it with a bolt or something to keep it together while the new part comes in?


Thanks all!
__________________
Just Truckin Around in the new 4x4 Ranger..... Till I'm in my lowered Tiburon, then I'm Avoiding Pot Holes....

Last edited by Black04Ranger; 05-11-2011 at 10:49 AM.
Reply With Quote
  #2  
Old 05-11-2011, 10:43 AM
HazardousRanger HazardousRanger is offline
Hazardous to Your Health!
 
Join Date: Jan 2011
Posts: 9,995
Default Re: HUGE POTHOLE... broke something on suspension

theres no pics
__________________
Ford Ranger Edge Supercab, 2004 3.0 Auto, 2WD, 4.10 Axle 31x10.5x15 BF Goodrich All Terrain T/A KO's


My Truck Is My Mountain Bike's Ride!

Class III hitch, Rhino Bedliner, Almost Maxed T-Bar Crank, Tuff Country Add A Leaf, Custom Low Anchor Points, OEM ('99) Tow Hooks, Pro Comp Offroad Lights , Mustang Dome Light, Clear Corners, Slim Toolbox, Blinker Mod,Cargo Brake Light Mod,Expo Lighted Visors, Ultra Silverstar heads/fogs, Fog/high mod, Reverse/switched lights, Bike Fork Mounts
Reply With Quote
  #3  
Old 05-11-2011, 10:49 AM
01_ranger_4x4 01_ranger_4x4 is offline
OIF Veteran

 
Join Date: Feb 2010
Posts: 6,043
Default Re: HUGE POTHOLE... broke something on suspension

thats just a swaybar link, you will be fine to drive it until you can replace it but you will probably notice a little more body roll and it will make some noise. its pretty cheap and simple to fix.
__________________
2001 Ranger 4x4 Stepside
-RCD Suspension lift
-33x12.5 BFG KM2's on Mickey Thomson classic locks
-4:56 gears
-Auburn gear LS
-James Duff traction bars
-Headers
-Flowmaster duals
-SCT X-Cal2 and some small exterior mods

http://www.cardomain.com/ride/2321189

2005 F-150 Lariat 4x4
-LED third brake light
-Weathertech floor liners
-Edge tuner
Reply With Quote
  #4  
Old 05-11-2011, 10:50 AM
Black04Ranger Black04Ranger is offline
New to Trucks...
 
Join Date: Mar 2010
Posts: 122
Default Re: HUGE POTHOLE... broke something on suspension

Quote:
Originally Posted by hazardousranger View Post
theres no pics
Pics added for ya.... i was in the process of saving them down... sry
__________________
Just Truckin Around in the new 4x4 Ranger..... Till I'm in my lowered Tiburon, then I'm Avoiding Pot Holes....
Reply With Quote
  #5  
Old 05-11-2011, 10:51 AM
High Class Country Ass High Class Country Ass is offline
Like the Forums
 
Join Date: Mar 2011
Posts: 40
Default Re: HUGE POTHOLE... broke something on suspension

the clunk sound might be CV joint related.. giving its when you turn sharply.
__________________
2002 RANGER STEPSIDE FX4
MODS: JVC H/U, Pioneer Speakers, Tinted Windows, OHC, Rhino Lined Bumpers, Hella 500 Rally lights, Antenna Delete, Headlight Mod.
Reply With Quote
  #6  
Old 05-11-2011, 10:51 AM
edgeman4.0 edgeman4.0 is offline
THE COMPLAINT DEPARTMENT
 
Join Date: Nov 2009
Posts: 3,962
Default

Its safe to drive home on that. Just take precautions going I to turns as you will have excessive body roll due to the sway bar not being attached. You can get a new end link from advanced auto parts or auto zone fairly cheap and swap them out with a basic set of hand tools in about ten minutes.

Sent from my DROIDX using Tapatalk
__________________
2001 Ford Ranger Supercab (4dr), Oxford White, 4.0 Sohc, 4x4, Manual trans (hurst equipped), 4:10's, 3" body lift.
Quote:
Originally Posted by Demon-FX4 View Post
The Edgeman sees his prey and strikes out from the darkness.
Quote:
Originally Posted by Rango88 View Post
Dont f+ck with Ch+ck
Reply With Quote
  #7  
Old 05-11-2011, 10:53 AM
Black04Ranger Black04Ranger is offline
New to Trucks...
 
Join Date: Mar 2010
Posts: 122
Default Re: HUGE POTHOLE... broke something on suspension

Quote:
Originally Posted by 01_ranger_4x4 View Post
thats just a swaybar link, you will be fine to drive it until you can replace it but you will probably notice a little more body roll and it will make some noise. its pretty cheap and simple to fix.
Thanks man! Do I have the right part identified in my Ebay link?

Also, can I ghetto rig it somehow to keep the swaybar and link together right now til the replacement part shows up?


How do I go about changing out the swaybar link? Can I do it all with the truck still on the ground? It looks as thought I could unbolt the remaining bolt from underneith the control arm, pull the broken part out, and put the new one in place and just tighten it down somehow?
__________________
Just Truckin Around in the new 4x4 Ranger..... Till I'm in my lowered Tiburon, then I'm Avoiding Pot Holes....
Reply With Quote
  #8  
Old 05-11-2011, 10:54 AM
HazardousRanger HazardousRanger is offline
Hazardous to Your Health!
 
Join Date: Jan 2011
Posts: 9,995
Default Re: HUGE POTHOLE... broke something on suspension

i wouldnt even bother ghetto rigging it
__________________
Ford Ranger Edge Supercab, 2004 3.0 Auto, 2WD, 4.10 Axle 31x10.5x15 BF Goodrich All Terrain T/A KO's


My Truck Is My Mountain Bike's Ride!

Class III hitch, Rhino Bedliner, Almost Maxed T-Bar Crank, Tuff Country Add A Leaf, Custom Low Anchor Points, OEM ('99) Tow Hooks, Pro Comp Offroad Lights , Mustang Dome Light, Clear Corners, Slim Toolbox, Blinker Mod,Cargo Brake Light Mod,Expo Lighted Visors, Ultra Silverstar heads/fogs, Fog/high mod, Reverse/switched lights, Bike Fork Mounts
Reply With Quote
  #9  
Old 05-11-2011, 10:55 AM
Black04Ranger Black04Ranger is offline
New to Trucks...
 
Join Date: Mar 2010
Posts: 122
Default Re: HUGE POTHOLE... broke something on suspension

Quote:
Originally Posted by edgeman4.0 View Post
Its safe to drive home on that. Just take precautions going I to turns as you will have excessive body roll due to the sway bar not being attached. You can get a new end link from advanced auto parts or auto zone fairly cheap and swap them out with a basic set of hand tools in about ten minutes.

Sent from my DROIDX using Tapatalk
Is this a part that they usually stock at autozone, or will I need to order it? Is that part I have on my ebay thread link in the first post the correct one? (so I'm sure I know what I'm looking for)
__________________
Just Truckin Around in the new 4x4 Ranger..... Till I'm in my lowered Tiburon, then I'm Avoiding Pot Holes....
Reply With Quote
  #10  
Old 05-11-2011, 11:08 AM
MTman777 MTman777 is offline
Back in black (kinda)
 
Join Date: Jan 2011
Posts: 1,276
Default Re: HUGE POTHOLE... broke something on suspension

thats the right part on that ebay link.. A very easy fix.. i did that to my ranger a while back..
__________________
00 Ford F-250...5.4L with some goodies, 4x4, Auto out of a 7.3 powerstroke w/ stage 2 TC , Crew Cab, Burnt orange, 35x12.5 MT Baja ATZ's on 20x10 Motometals, Pioneer Deck, Scanguage, Magnaflow exhaust, LED signal tow mirrors, and a Hidden hitch gooseneck
Reply With Quote
  #11  
Old 05-11-2011, 11:21 AM
Black04Ranger Black04Ranger is offline
New to Trucks...
 
Join Date: Mar 2010
Posts: 122
Default Re: HUGE POTHOLE... broke something on suspension

Quote:
Originally Posted by MTman777 View Post
thats the right part on that ebay link.. A very easy fix.. i did that to my ranger a while back..
How do you go about pulling the old one off and putting the new one on? Is it as easy as just breaking the nuts free and pulling it out?

Do you know the specific tightening torque to use on the bolts, any threadlock required, or what mm sockets I need? reason I ask is because unfortunately I'm out of town right now and won't be back home til monday afternoon.... so I'm going to be replacing this part with just a basic socket set and wrench out in front of the hotel.
(FIGURES IT WOULD HAPPEN WHILE I'M AWAY!)


Wanna give me a quick 3-second rundown on what process I need to follow to replace it? I'm sure its easy and I'll laugh when I get out there to do it, just want to be prepared since I don't have my normal tools to work with.

THANKS GUYS! FRF is the BEST!
__________________
Just Truckin Around in the new 4x4 Ranger..... Till I'm in my lowered Tiburon, then I'm Avoiding Pot Holes....
Reply With Quote
  #12  
Old 05-11-2011, 11:28 AM
MTman777 MTman777 is offline
Back in black (kinda)
 
Join Date: Jan 2011
Posts: 1,276
Default Re: HUGE POTHOLE... broke something on suspension

Theres just bolts on the ends of the sway bar links.. just take the nuts off of them and theyll come right off.. New ones just bolt into place.. Front Stabilizer Bar Bracket Bolts 34-46 Nm (25-34 ft. lbs.) That should be the right torque specs..
__________________
00 Ford F-250...5.4L with some goodies, 4x4, Auto out of a 7.3 powerstroke w/ stage 2 TC , Crew Cab, Burnt orange, 35x12.5 MT Baja ATZ's on 20x10 Motometals, Pioneer Deck, Scanguage, Magnaflow exhaust, LED signal tow mirrors, and a Hidden hitch gooseneck
Reply With Quote
  #13  
Old 05-11-2011, 11:40 AM
Black04Ranger Black04Ranger is offline
New to Trucks...
 
Join Date: Mar 2010
Posts: 122
Default Re: HUGE POTHOLE... broke something on suspension

Awesome man.... really appreciate it.

Oh... but only 25-34ft lbs of torque.... that doesnt seem like much at all... lol
__________________
Just Truckin Around in the new 4x4 Ranger..... Till I'm in my lowered Tiburon, then I'm Avoiding Pot Holes....
Reply With Quote
  #14  
Old 05-11-2011, 11:50 AM
MTman777 MTman777 is offline
Back in black (kinda)
 
Join Date: Jan 2011
Posts: 1,276
Default Re: HUGE POTHOLE... broke something on suspension

Yeah.. theyre really not holding any weight so they dont have a high torque spec
__________________
00 Ford F-250...5.4L with some goodies, 4x4, Auto out of a 7.3 powerstroke w/ stage 2 TC , Crew Cab, Burnt orange, 35x12.5 MT Baja ATZ's on 20x10 Motometals, Pioneer Deck, Scanguage, Magnaflow exhaust, LED signal tow mirrors, and a Hidden hitch gooseneck
Reply With Quote
  #15  
Old 05-12-2011, 06:02 AM
Black04Ranger Black04Ranger is offline
New to Trucks...
 
Join Date: Mar 2010
Posts: 122
Default Re: HUGE POTHOLE... broke something on suspension

Well guys I just fixed the link last night..... what a LOT of work for such an easy part!

Here's what happened, since the top of the nut got shaved clean off in the break, there was nothing to hold on to and the bolt underneith would just spin the entire assembly in place.... so I think, ok Vice grips! Put those on there.... so much corrosion the wratchet began to overpower the vice grips and spin the part in them.... CRAP!

So now I busted out the PB blaster.... sprayed the bolt down and wiped it off, then sprayed again and wiped off, and again, and again..... then used a hammer and smacked the end of the bolt a few times to try and loosen it. Back to the vice grips and breaker bar wratchet.... Still NOTHING! sealed harder than all hell.

OK.... now for the big guns, out comes the protable butane torch to try and heat it up and break it free..... Heated it up a few times and tried to crack this bolt from hell free.... STILL WON'T COME FREE!

Now I'm fed up, I get out my portable dremel with steel cutting blade.... As these are reinforced steel it took a while, but I managed to cut off the part of the nut that was corroded to the bolt.... PROGRESS..... I manage to now crack the bolt free of the original position... but the threads are so gone I can't back it down the shaft.....

So out comes the breaker bar and wratchet, and PB blaster, and torch all at the same time going at it.... and FINALLY after about an hour of messing around I got that stupid lock nut off of the shaft and slid the old Sway Bar Link out of place!!!!

Stopped for a second to sing "we are the champions" to myself.


Now for the good stuff.... it took all of about 1 minute to get the new sway bar link on and in place! No more clunk noise, and it rides good as new! Thanks again for all your guys help and suggestions.

Here is a picture of my spoils of war:
__________________
Just Truckin Around in the new 4x4 Ranger..... Till I'm in my lowered Tiburon, then I'm Avoiding Pot Holes....
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Craigslist / eBay Find: Huge Ranger Kerick Humorous Classified Finds 13 02-01-2011 03:25 PM
Craigslist / eBay Find: Huge 99 01DangerRanger Trucks 2 01-10-2011 03:22 PM
Got bored.... Huge changes!! 04RangerFX2 Vehicle Snapshots 46 10-07-2010 10:52 PM
Huge Moose!! PhunkyMunky Off Topic 20 06-05-2010 12:09 PM
Huge ranger 878ranger878 General Ford Ranger Discussion 1 03-06-2010 11:17 PM