Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 08-31-2010, 02:58 PM
TurdFX4 TurdFX4 is offline
Sept. 2011 TOTM
 
Join Date: Jan 2010
Posts: 1,771
Default Suspension/Axle Issue?

Lately Ive been having a noise coming from the driver side front of my truck. ('03 4x4) Its almost like a clunking noise when hitting some bumps and sometimes while turning. I jacked my truck up and found 3 things that seemed a little unordinary:

1. My CV axle seems like its seperated from the axle housing it self, only about a pinky tip width though, but there is oil on the part of the CV closest to the diff, best pic I could get:



2. This is my Fairly new Moog UCA with Moog BJ, installed near the end of may, beginning of june. the only thing thats a little off is that it seems like its leaking grease. I put the wheel back on and tightened the wheel and did the Ball Joint check and it didnt move so that leaves me to believe that its not the Ball Joints:



3. There's a little bit of a gap in between my lugs and my rotor holes, I noticed when I turn the lugs by hand, they hit the rotor and make a noise similar to what Ive been hearing:




On the driver side Ive replaced (all within the past few months) Moog Upper control arm with moog ball joint, new wheel bearing/hub assembly, and the cv axle twice. The shocks were put on winter of '08 so they might be bad ( I did live in OK for 4 months lol) The rotors and pads have been replaced in the 3-1/2 years Ive had the truck.

Let me know what you guys think!

-Adam
Reply With Quote
  #2  
Old 08-31-2010, 06:44 PM
TurdFX4 TurdFX4 is offline
Sept. 2011 TOTM
 
Join Date: Jan 2010
Posts: 1,771
Default Re: Suspension/Axle Issue?

Nevermind, figured out what it was
Reply With Quote
  #3  
Old 08-31-2010, 07:10 PM
mickblock mickblock is offline
Get off my lawn
 
Join Date: Apr 2010
Posts: 1,059
Default Re: Suspension/Axle Issue?

What was it!? Was it a shock or a bushing? I was gonna answer but I'm styoopid, but I'm still interested. My wifes Honda is starting to do exactly what you described and I haven't even looked at it yet.
__________________
08 4.0 Sport 4x4
Stock
Reply With Quote
  #4  
Old 08-31-2010, 07:16 PM
TurdFX4 TurdFX4 is offline
Sept. 2011 TOTM
 
Join Date: Jan 2010
Posts: 1,771
Default Re: Suspension/Axle Issue?

My upper control arm was loose lol. both bolts that hold it on were loose, the back one worse than the front one, Im gonna take them off tomorrow and threadlock the shit outta em so they dont work loose again
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Suspension issue maybe....?? Bertdogg Suspension Tech 7 08-25-2010 08:35 PM
4.10 to 3.55 axle smurphy Drivetrain Tech 8 04-24-2010 11:22 AM
axle help talkington Drivetrain Tech 1 01-08-2010 02:21 AM
new axle?? talkington Drivetrain Tech 8 01-06-2010 10:38 PM
Need help with axle Ranger01 Drivetrain Tech 23 12-11-2009 06:48 PM