Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 01-23-2015, 09:45 PM
corvairbob corvairbob is offline
Like the Forums
 
Join Date: Jan 2015
Posts: 47
Default steering noise

i just got an 01 ranger 3.0 with auto and i notice that the steering make a squeaking noise when turning the wheel more to the right than the left. i sounds like it is rubbing some rubber grommet somewhere. i see the column going into the rack has a rubber grommet on it and o'm wondering if that may be the area making the noise. has anyone had this? i put some wd40 on it but i did not yet notice a difference it may take some time to get the wd40 into the area that is making the noise.


i think i may have found this problem but will not know for sure untill i repair what i found. when i was putting the truck up on jack stands as i was lifting the fron it was making a sound that sounded like the ball joints were rubbing with out any grease. the boots are borken on the joints all of them and one looked real rusted. so that just may be the problem, this ball joint was grinding and that sounded like rubber squeaking? and it did it worse turning to the right than to the left and that ball joint was the lower right one. so i will replace all the ball joints this week.


anyone have this same problem let me know. thanks

Last edited by corvairbob; 01-24-2015 at 05:24 PM.
Reply With Quote
Reply

Tags
grommet, noise, rubber, steering, wd40

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Steering noise tyler fox 3.0 Vulcan Tech 11 01-13-2014 12:45 PM
01 - Power steering noise computersoc General Tech 32 07-04-2013 05:57 AM
Steering noise triplessun47 Drivetrain Tech 1 11-03-2012 06:26 PM
Noise When Steering IrideAHonda General Ford Ranger Discussion 14 07-15-2011 06:04 AM
Steering noise question woffler General Tech 1 10-29-2010 07:25 AM