Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Showing results 1 to 11 of 11
Search took 0.00 seconds.
Search: Posts Made By: Tomslick66
Forum: General Tech 03-15-2010, 09:48 AM
Replies: 17
Views: 7,964
Posted By Tomslick66
Re: Smell of gas?

I know this will sound crazy but I had the same problem and it was the valve stem on the fuel rail. I only found it by shining a flashlight on the intake manifold. Lots of gas from a little leak. It...
Forum: 3.0 Vulcan Tech 03-11-2010, 01:23 PM
Replies: 16
Views: 2,843
Posted By Tomslick66
Re: odd noise

Have fun replacing your engine.
Forum: 3.0 Vulcan Tech 03-10-2010, 08:58 PM
Replies: 16
Views: 2,843
Posted By Tomslick66
Re: odd noise

What part of "Camshaft position sensor/synchronizer turns the oil pump" did not register? This takes the place of the distributor shaft since the distributor no longer exists on these vehicles. I'm...
Forum: 3.0 Vulcan Tech 03-08-2010, 12:40 PM
Replies: 16
Views: 2,843
Posted By Tomslick66
Re: odd noise

Think about it, why is this area not getting lube? Everything inside of your engine is designed to be lubed by the oil pump. No lube at the top of the engine means there is a problem. When the...
Forum: 4.0 SOHC / 4.0 OHV Tech 03-07-2010, 09:41 PM
Replies: 10
Views: 3,644
Posted By Tomslick66
Re: abs light

It's in the rear differential, front side, on top, kinda over the last u-joint on the drive shaft. There's only one bolt holding it in but it's a pain to reach from under the truck. Make sure to...
Forum: 2.9 Liter Tech 03-07-2010, 09:03 PM
Replies: 10
Views: 2,599
Posted By Tomslick66
Re: sounds like theres something loose

Check the metal washer on the carrier bearing in the middle of your driveshaft. If it's loose the noise can drive you crazy. (If you don't have the 2 piece driveshaft, ignore this post!)
Forum: 3.0 Vulcan Tech 03-07-2010, 08:11 PM
Replies: 5
Views: 4,317
Posted By Tomslick66
Re: Temperature guage

You could unplug the wire from the sending unit and ground it. If the temp gauge pegs out it's the sensor. No special tools needed, almost idiot proof but I've worked with some exceptional idiots!
Forum: 3.0 Vulcan Tech 03-07-2010, 08:05 PM
Replies: 16
Views: 2,843
Posted By Tomslick66
Re: odd noise

If the noise is coming from the top rear of the engine, it is very likely it is the cam position sensor/ synchro. If so, fix it asap. This drives your oil pump! When it quits making the irritating...
Forum: 4.0 SOHC / 4.0 OHV Tech 03-07-2010, 08:00 PM
Replies: 10
Views: 3,644
Posted By Tomslick66
Re: abs light

Had the same problem in my 95. Pulled the VSS, cleaned it with electrical cleaner, no mo ABS light! (The light still works, but like it's supposed to. Thought I'd better make that clear.)
Forum: 3.0 Vulcan Tech 03-07-2010, 07:53 PM
Replies: 3
Views: 3,399
Posted By Tomslick66
Re: Oil pan removal question

I've been working on getting my oil pan off till the wife is ready to blow it up with me under it. Tomorrow I will just pull the engine like I should have done to start with. I followed all the...
Forum: General Tech 03-07-2010, 07:36 PM
Replies: 9
Views: 2,054
Posted By Tomslick66
Re: Take a wild guess!

The oil pressure gauge on these Rangers is basically an idiot light, if it reads over about 7 psi it will read normal on the dash. Replace it with an aftermarket Sunpro if you want to know for sure...
Showing results 1 to 11 of 11