Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Showing results 1 to 8 of 8
Search took 0.01 seconds.
Search: Posts Made By: jeffro3006
Forum: Suspension Tech 04-06-2013, 06:15 PM
Replies: 13
Views: 3,672
Posted By jeffro3006
Re: Ranger wobble when hits a bump

Check your sway/stabilization bar links, they might just be snapped. Autozone has replacements for $13 a pop. Going to install them tomorow.
Forum: Suspension Tech 04-06-2013, 10:35 AM
Replies: 1
Views: 902
Posted By jeffro3006
Re: Missing Stabalizer Bar Stud and Bushing?/Torsion bar wearing?

Correction: I believe I'm missing the link bolt-does this sound right?
...
Forum: Suspension Tech 04-06-2013, 10:15 AM
Replies: 1
Views: 902
Posted By jeffro3006
Question Missing Stabalizer Bar Stud and Bushing?/Torsion bar wearing?

Ok, so I bought my 2004 Edge RWD Regular Cab used with 156K miles on it as my first car about 9 months ago. Absolutely nothing mechanically wrong with it that has come up since buying it. The ride...
Forum: 3.0 Vulcan Tech 09-18-2012, 03:45 AM
Replies: 5
Views: 794
Posted By jeffro3006
Re: Weird RPM fluxuation after shifting into P/R

Good point! Might be worth looking into
Forum: 3.0 Vulcan Tech 09-17-2012, 04:52 PM
Replies: 5
Views: 794
Posted By jeffro3006
Re: Weird RPM fluxuation after shifting into P/R

Thank you very much!
Figuring that it's probably just the initial load after shifting into gear now...not gonna worry about it untill it really becomes a problem.
Forum: Introduce Yourself 09-17-2012, 04:50 PM
Replies: 8
Views: 370
Posted By jeffro3006
Re: Newbie!

Thanks all!
Forum: Introduce Yourself 09-16-2012, 07:16 AM
Replies: 8
Views: 370
Posted By jeffro3006
Newbie!

Hey, so joined up since just got my first car (ranger!!!). Having a minor engine issue with the RPMs so please help! (Think I got that thread in the right area)
Forum: 3.0 Vulcan Tech 09-16-2012, 07:12 AM
Replies: 5
Views: 794
Posted By jeffro3006
Question Weird RPM fluxuation after shifting into P/R

Hey, so I'm new here- shocker!
So I just got my '04 ranger with an auto transmission and 3L v6 . Whenever I shift into park or reverse from a cold start-up out of park, the RPMs fluxuate up to...
Showing results 1 to 8 of 8