Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Showing results 1 to 25 of 252
Search took 0.01 seconds.
Search: Posts Made By: JSobo
Forum: 3.0 Vulcan Tech 11-23-2015, 08:52 PM
Replies: 13
Views: 1,140
Posted By JSobo
Re: Replaced fuel pump, less than 150 miles later P0305 and P0316 CEL

I posted that right after doing the compression test, afterward I put everything back on and fired it up and it ran good without spitting out a code. Go figure.
Forum: 3.0 Vulcan Tech 11-23-2015, 11:13 AM
Replies: 13
Views: 1,140
Posted By JSobo
The mystery is solved on the motor - 120 psi on...

The mystery is solved on the motor - 120 psi on #4 cyl, #5 40 psi so that's the heads right? I didn't warm it up but even so that is a big difference.

Now I have to either try and part it out...
Forum: 3.0 Vulcan Tech 11-23-2015, 02:08 AM
Replies: 13
Views: 1,140
Posted By JSobo
Re: Replaced fuel pump, less than 150 miles later P0305 and P0316 CEL

:)
It's not coolant, I know that smell all too well. It is an indescribable smell, kind of like stale B.O. - we have a combo of several oder absorbers and air fresheners kind of hiding it. For the...
Forum: 3.0 Vulcan Tech 11-22-2015, 07:56 PM
Replies: 13
Views: 1,140
Posted By JSobo
Re: Replaced fuel pump, less than 150 miles later P0305 and P0316 CEL

It's a 2003, I'm at least the 3rd owner and by appearances it's lived a hard life. I do not think the original owner took very good care of it.

Don't get me wrong it's been pretty loyal for us but...
Forum: 3.0 Vulcan Tech 11-22-2015, 06:28 PM
Replies: 13
Views: 1,140
Posted By JSobo
Re: Replaced fuel pump, less than 150 miles later P0305 and P0316 CEL

I was wondering about that. I'm going to have to figure out how to test it.

Right now I'm at a crossroads with this truck, it has 182,000 miles on it, in the last month I've replaced the idler...
Forum: 3.0 Vulcan Tech 11-22-2015, 12:19 AM
Replies: 13
Views: 1,140
Posted By JSobo
Re: Replaced fuel pump, less than 150 miles later P0305 and P0316 CEL

A misfire on #5?

There's nothing chirping and no cam codes. The cam sensor and shaft that's on there has maybe 40,000 miles on it.

If it's got something to do with it is it both pieces or...
Forum: 3.0 Vulcan Tech 11-21-2015, 04:53 PM
Replies: 13
Views: 1,140
Posted By JSobo
Replaced fuel pump, less than 150 miles later P0305 and P0316 CEL

My fuel pump finially took a dump so I replaced it with a new Motorcraft pump. I forgot to get a filter, after replacing the pump I drove it about 5 miles round trip to get a filter.

Last Monday...
Forum: 3.0 Vulcan Tech 11-21-2015, 04:31 PM
Replies: 5
Views: 810
Posted By JSobo
Re: New Motorcraft spark plug damaged out of the box

If I wasn't already having issues, I would have probably used it but I ended up taking it back, putting up a new thread for the problems now...
Forum: 3.0 Vulcan Tech 11-21-2015, 03:55 PM
Replies: 52
Views: 5,410
Posted By JSobo
Forum: 3.0 Vulcan Tech 11-18-2015, 03:52 AM
Replies: 5
Views: 810
Posted By JSobo
New Motorcraft spark plug damaged out of the box

Went to O'Reilly to get plugs - 1st trip I was given the wrong plugs. Noticed the part number while gapping them, luckily I recognized it wasn't right before installing them. 2nd trip, right plugs...
Forum: 3.0 Vulcan Tech 11-04-2015, 08:08 PM
Replies: 3
Views: 532
Posted By JSobo
Re: Fuel pump/sending unit replacement

I just bought a Motorcraft from Amazon for $350, I have the 118" wheelbase which has even less options - my wallet wanted to go aftermarket but there seems to be a lot of complaints for aftermarket....
Forum: 3.0 Vulcan Tech 11-02-2015, 05:53 PM
Replies: 2
Views: 420
Posted By JSobo
Re: Fuel Pump

They sell those strainers that are an add on-

Are those necessary?

Are they generic? Will any brand fit onto Motorcraft pump?
Forum: 3.0 Vulcan Tech 11-02-2015, 12:09 PM
Replies: 20
Views: 1,486
Posted By JSobo
Re: AC or Power-steering pump ~ Video incl..

I think it is (was) the belt tensioner, the chirping has (so far) gone away after replacing the tensioner, belt and idler pulley. Normally I wouldn't be so sure after replacing three parts at once...
Forum: 3.0 Vulcan Tech 11-02-2015, 11:37 AM
Replies: 2
Views: 420
Posted By JSobo
Fuel Pump

At the beginning of the year, I had a few no starts and took it to a shop for an opinion. They said fuel pump looked iffy and for sure the check valve was bad, they said it wasn't holding pressure,...
Forum: 3.0 Vulcan Tech 10-01-2015, 01:01 AM
Replies: 20
Views: 1,486
Posted By JSobo
Re: AC or Power-steering pump ~ Video incl..

After tightening the bolt on the tensioner and removing the idler pulley to check the bearings the chirp seemed to go away for a little over a week, now it's back with a vengeance. I believe it is...
Forum: 3.0 Vulcan Tech 09-20-2015, 03:50 AM
Replies: 20
Views: 1,486
Posted By JSobo
Re: AC or Power-steering pump ~ Video incl..

Yes - no squeaks, chirps or rattles.
Forum: 3.0 Vulcan Tech 09-19-2015, 08:22 PM
Replies: 20
Views: 1,486
Posted By JSobo
Re: AC or Power-steering pump ~ Video incl..

When it first started making the noise I replaced the belt and the idler pulley. Belt is a Gatorback (I'm thinking of just ordering a new one from Amazon - no longer from Goodyear, now they are...
Forum: 3.0 Vulcan Tech 09-19-2015, 06:10 PM
Replies: 20
Views: 1,486
Posted By JSobo
Re: AC or Power-steering pump ~ Video incl..

Took the serpentine belt off - no chirp, belt looks good, no glazing, no cracks or missing ribs - nothing.

Took idler pulley off, appears to be ok.

So I'm in the same place I was, no idea.
Forum: 3.0 Vulcan Tech 09-18-2015, 03:31 PM
Replies: 20
Views: 1,486
Posted By JSobo
So when I pull the belt, if it's still chirping...

So when I pull the belt, if it's still chirping it's the cam sync. If it stops what is the next thing to look at, the tensioner?

I'm fairly certain that the cam sync is OK, since this started...
Forum: 3.0 Vulcan Tech 09-18-2015, 01:45 PM
Replies: 20
Views: 1,486
Posted By JSobo
It was replaced a few years ago. ---------- ...

It was replaced a few years ago.

----------



Will do later this evening or early tomorrow.
Forum: 3.0 Vulcan Tech 09-18-2015, 03:51 AM
Replies: 20
Views: 1,486
Posted By JSobo
The only thing that I see is some weird wear on...

The only thing that I see is some weird wear on the paint on the idler pulley, dug up the old one and it had similar wear, but more on the edge closer inside edge (closer to the bracket), less on the...
Forum: 3.0 Vulcan Tech 09-17-2015, 06:09 PM
Replies: 20
Views: 1,486
Posted By JSobo
Re: AC or Power-steering pump ~ Video incl..

I added new links to videos on Google drive - I hate photobucket but Google was stuck processing the videos for an hour and I wanted to get this posted

----------



That was the first thing I...
Forum: 3.0 Vulcan Tech 09-17-2015, 02:34 PM
Replies: 20
Views: 1,486
Posted By JSobo
AC or Power-steering pump ~ Video incl..

Chirping sound coming from the front of the motor in the area of the AC compressor, power-steering pump.
I thought it was the AC clutch but now I'm not so sure. It doesn't seem to do it when the...
Forum: 3.0 Vulcan Tech 04-29-2015, 01:39 PM
Replies: 4
Views: 623
Posted By JSobo
I bought a Lisle stethoscope to isolate the sound...

I bought a Lisle stethoscope to isolate the sound after I replaced the idler pulley and belt and it was still squeaking. It's coming from the AC compressor, louder by the pulley - so I'm pretty sure...
Forum: 3.0 Vulcan Tech 04-26-2015, 03:30 PM
Replies: 4
Views: 623
Posted By JSobo
No it's squeaking, squeezing whatever you want to...

No it's squeaking, squeezing whatever you want to call it. It clicks really loud when it engages/disengages - louder than any vehicle I've ever owned as far as I can remember but yea, that isn't what...
Showing results 1 to 25 of 252