Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Showing results 1 to 9 of 9
Search took 0.03 seconds.
Search: Posts Made By: joeaguilar
Forum: 4-Cylinder Tech 06-15-2011, 05:13 PM
Replies: 9
Views: 7,737
Posted By joeaguilar
Re: 1996 Ranger 2.3l misfire

I don't know if it would cause just on perticular cylinder, but it will cause the engine to missfire. My truck would run good for about 20 to 30 min then start missing! At idle it was smooth untill I...
Forum: 4-Cylinder Tech 06-14-2011, 06:52 PM
Replies: 9
Views: 7,737
Posted By joeaguilar
Re: 1996 Ranger 2.3l misfire

Check your crank sensor. I had the same problem on my 97 2.3. I went thru the same freaking routine! Try that befor you get to your injectors. Worth a try!
Forum: 4-Cylinder Tech 06-08-2011, 08:16 PM
Replies: 4
Views: 2,443
Posted By joeaguilar
Re: 98 2.5 missing and then it doesn't

I had the same problem, truck would run fine then miss bad... Changed plugs, wires and coil packs, turns out it was the crank sensor, it was broken all the way around. Since changing the sensor truck...
Forum: 4-Cylinder Tech 06-08-2011, 07:38 PM
Replies: 155
Views: 16,573
Posted By joeaguilar
Re: i wanna see who has the miles on their 2.5L

Ok it's not a 2.5, but had to post 97 2.3L 289,000!!! 288,000 on Factory plugs, coil packs and S/P wires!!! I've had that truck since 2000 with no problems till recently, tune up, coil packs and...
Forum: 4.0 SOHC / 4.0 OHV Tech 06-07-2011, 06:59 PM
Replies: 5
Views: 10,187
Posted By joeaguilar
Re: 1996 Ranger crankshaft position sensor

I have a 97 2.3 2wd. Mine was wissing on accelaration!!! Replaced the crank sensor and all is good! Not sure on the 4.0, but mine is on the left side of the harmonic balencer looking at the engine....
Forum: 4-Cylinder Tech 06-06-2011, 09:11 PM
Replies: 10
Views: 1,307
Posted By joeaguilar
Re: Running stright water?

It's about that hot inside my Ranger this time of year! LOL Dam heat won't stop!!!
Forum: 4-Cylinder Tech 06-06-2011, 09:02 PM
Replies: 32
Views: 16,929
Posted By joeaguilar
Re: hesitation and missing on acceleration

@ fratumus I changed both coil packs ran good fo a bit then the same thing. Just took out my crank sensor and it was broke all the way around!!! It wasn't the removal cause I was easy on it!!! Air...
Forum: 4-Cylinder Tech 06-06-2011, 03:29 PM
Replies: 32
Views: 16,929
Posted By joeaguilar
Re: hesitation and missing on acceleration

Crank shaft sensor is the problem with my 97 2.3L. Code was P0320 Bad harness or bad ssensor. Bought the sensor and will replace this evening, when it cools down! It will cause it to miss when the...
Forum: 4-Cylinder Tech 06-04-2011, 09:17 PM
Replies: 32
Views: 16,929
Posted By joeaguilar
Re: hesitation and missing on acceleration

I had the same problem with my 97 Ranger 2wd. It only would start missing when the engine came to temp. I replaced plugs and wires, but she still ran rough. So next step replaced both coil packs and...
Showing results 1 to 9 of 9