Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Showing results 1 to 25 of 230
Search took 0.01 seconds.
Search: Posts Made By: TxGasRacer
Forum: 4.0 SOHC / 4.0 OHV Tech 07-07-2018, 06:54 AM
Replies: 4
Views: 875
Posted By TxGasRacer
Re: 98 ranger 4.0 lean in both banks puzzled

It is more than likely your upper intake o-ring gaskets. I have a 1998 4.0 super cab and I had this happen to me,after I changed out the upper intake o-ring gaskets my lean trouble codes p0171 and...
Forum: 4.0 SOHC / 4.0 OHV Tech 08-29-2017, 11:44 AM
Replies: 2
Views: 1,120
Posted By TxGasRacer
Re: P0174

http://www.fordrangerforum.com/4-0-sohc-4-0-ohv-tech/15560-01-4-0-lean-codes-po171-po174-look.html
Forum: General Ford Ranger Discussion 08-19-2017, 03:08 PM
Replies: 12
Views: 702
Posted By TxGasRacer
Re: front main seal

Unbolt it from the flexplate but leave it on the trans shaft so you dont make a mess with trans fluid
Forum: 4.0 SOHC / 4.0 OHV Tech 06-20-2017, 11:11 AM
Replies: 40
Views: 2,519
Posted By TxGasRacer
Forum: General Tech 03-19-2017, 09:26 AM
Replies: 1
Views: 477
Posted By TxGasRacer
Re: Throttle position sensor issues

The reving up and then back down is more than likely going to be your Idle Air Control Valve and you will either have to clean yours out OR buy a new one and replace your old one.
Forum: Electrical Tech 11-17-2016, 06:30 AM
Replies: 1
Views: 474
Posted By TxGasRacer
Re: Truck wont start

http://troubleshootmyvehicle.com/ford/4.0L/how-to-test-a-no-start-condition-1
Forum: General Tech 09-13-2016, 07:00 AM
Replies: 3
Views: 530
Posted By TxGasRacer
Re: Crank/No Start 93 XLT

The link is for the 2.3 ltr and good luck.
Forum: General Tech 09-12-2016, 11:50 PM
Replies: 3
Views: 530
Posted By TxGasRacer
Re: Crank/No Start 93 XLT

http://easyautodiagnostics.com/ford/2.3L/icm-and-crank-sensor-tests-1
Forum: 4.0 SOHC / 4.0 OHV Tech 08-31-2016, 11:15 AM
Replies: 32
Views: 2,447
Posted By TxGasRacer
Re: P0174 Lean Condition Bank 2 - getting desperate

Look through the second link I posted it gives a step by step procedure to identify problems. ...
Forum: 4.0 SOHC / 4.0 OHV Tech 08-31-2016, 08:39 AM
Replies: 32
Views: 2,447
Posted By TxGasRacer
Re: P0174 Lean Condition Bank 2 - getting desperate

http://www.fordrangerforum.com/4-0-sohc-4-0-ohv-tech/15560-01-4-0-lean-codes-po171-po174-look.html ...
Forum: 4.0 SOHC / 4.0 OHV Tech 08-24-2016, 09:12 AM
Replies: 2
Views: 538
Posted By TxGasRacer
Re: Help locating the vacuum reservoir.

take down your passenger side inner fender well and the vaccum reservoir ball will be mounted to the lower area of the inner fender well close to the fire wall,but you can not see it untill you drop...
Forum: 4.0 SOHC / 4.0 OHV Tech 08-11-2016, 07:03 AM
Replies: 3
Views: 734
Posted By TxGasRacer
Re: 99 Ford Ranger ABS codes and brae problem

C1230 Rear Axle Wheel Speed Sensor Input Circuit
Failure
Note: DTC...
Forum: 4.0 SOHC / 4.0 OHV Tech 08-05-2016, 07:38 AM
Replies: 9
Views: 1,051
Posted By TxGasRacer
Re: External Head gasket Leak

Inlet Air Temp Sensor
Forum: 4.0 SOHC / 4.0 OHV Tech 07-20-2016, 11:37 AM
Replies: 5
Views: 1,029
Posted By TxGasRacer
Re: 2000 Ranger P0133 P0153 Drive into lake and report stolen?

http://troubleshootmyvehicle.com/ford/4.0L/troubleshooting-P0171-and-P0174-page-1
Forum: 4-Cylinder Tech 07-19-2016, 09:10 PM
Replies: 9
Views: 1,017
Posted By TxGasRacer
Re: p0171 lean code won't go away

http://troubleshootmyvehicle.com/ford/4.0L/troubleshooting-P0171-and-P0174-page-1
Forum: General Tech 06-18-2016, 09:10 AM
Replies: 2
Views: 473
Posted By TxGasRacer
Re: Truck won't start while hot

http://troubleshootmyvehicle.com/ford/4.0L/how-to-test-the-alternator-1 http://troubleshootmyvehicle.com/ford/4.0L/how-to-test-the-starter-motor-1 ...
Forum: 3.0 Vulcan Tech 06-17-2016, 03:30 PM
Replies: 1
Views: 544
Posted By TxGasRacer
Re: crank no start

http://troubleshootmyvehicle.com/ford/4.0L/how-to-test-a-no-start-condition-1
Forum: General Tech 05-25-2016, 08:55 AM
Replies: 1
Views: 555
Posted By TxGasRacer
Re: How do I remove and replace the windshield fluid jets?

There is a small metal bracket under the hood that needs to be removed to take the washer jets out from below the hood.
Forum: 4.0 SOHC / 4.0 OHV Tech 05-24-2016, 05:40 PM
Replies: 3
Views: 452
Posted By TxGasRacer
Re: temp gauge not moving. Truck runs fine. sending unit replaced, radiator flushed.

did you replace the correct temp sensor ? there are two of them and the sensor with one wire going to it is the correct water temp sensor. The other sensor has two wires and is used by the computor.
Forum: 3.0 Vulcan Tech 05-13-2016, 07:15 PM
Replies: 1
Views: 495
Posted By TxGasRacer
Re: Multiple Cylinders Misfiring.

http://troubleshootmyvehicle.com/ford/3.0L-3.8L/how-to-diagnose-a-misfire-1
Forum: 3.0 Vulcan Tech 05-07-2016, 01:42 PM
Replies: 2
Views: 544
Posted By TxGasRacer
Re: coolant temp sensor

The single wire sensor is for your temp gage, the two wire sensor is used by the PCM.
Forum: 4.0 SOHC / 4.0 OHV Tech 05-02-2016, 06:23 PM
Replies: 4
Views: 519
Posted By TxGasRacer
Re: Where does this wire plug in?

radio noise suppressor hookup plug
Forum: General Tech 05-02-2016, 08:57 AM
Replies: 2
Views: 557
Posted By TxGasRacer
Re: Driver's Window Rolls Up Crooked

There is a small bracket that is spot welded to your rear window track and the mounting bolt goes through part of this to attach the back side window track to the inside of your door.Oh my truck this...
Forum: General Tech 05-02-2016, 08:52 AM
Replies: 2
Views: 474
Posted By TxGasRacer
Re: MAS Sensor problems

http://troubleshootmyvehicle.com/ford/4.9L-5.0L-5.8L/how-to-clean-the-ford-mass-air-flow-sensor-1
Forum: Electrical Tech 04-26-2016, 07:47 AM
Replies: 10
Views: 753
Posted By TxGasRacer
Re: Wont start crank or click ?

http://troubleshootmyvehicle.com/ford/3.0L-3.8L/troubleshooting-a-no-start-condition-1
Showing results 1 to 25 of 230