Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Showing results 1 to 11 of 11
Search took 0.02 seconds.
Search: Posts Made By: Hawkeye59
Forum: Electrical Tech 12-07-2011, 01:53 PM
Replies: 1
Views: 478
Posted By Hawkeye59
89 Mustang start issue

Brief history: I used this mustang to jump my Ranger exactly one year ago this month. In doing so I had the jumpers on the truck backwards and blew a mega fuse and also damaged the alternator in the...
Forum: Electrical Tech 03-30-2011, 06:42 AM
Replies: 30
Views: 5,093
Posted By Hawkeye59
Re: Battery dead after 4 to 5 day non use of truck

Late follow up: Alternator change fixed the issue. I can now go at least 15 days without starting it and it starts just fine.
Forum: General Tech 12-21-2010, 08:19 AM
Replies: 9
Views: 2,404
Posted By Hawkeye59
Re: Result of improper jumper cable hookup question

Well after all that mess they say all I did is blow a mega fuse under the hood.
Forum: Electrical Tech 12-20-2010, 05:05 PM
Replies: 30
Views: 5,093
Posted By Hawkeye59
Re: Battery dead after 4 to 5 day non use of truck

Its flashing I guess about every 2 seconds and there is no glove box light.

Yea it would be nice if i could do it myself but my knowledge base is in 20 years of military aircraft engines, props...
Forum: General Tech 12-20-2010, 10:07 AM
Replies: 9
Views: 2,404
Posted By Hawkeye59
Re: Result of improper jumper cable hookup question

Its going to the shop today so ill report back on the damages.
Forum: Electrical Tech 12-20-2010, 10:02 AM
Replies: 30
Views: 5,093
Posted By Hawkeye59
Re: Battery dead after 4 to 5 day non use of truck

The only lights active with ignition off are fords theft deterrent light and yes its suppose to flash and the non factory stereo red light that blinks for what ever reason. Some kind of deterrent...
Forum: Electrical Tech 12-20-2010, 06:46 AM
Replies: 30
Views: 5,093
Posted By Hawkeye59
Re: Battery dead after 4 to 5 day non use of truck

The only things I can think of are the constant flashing theft deterrent lamp in gauge area and the flashing red lamp they put in car stereos that flash when head is off.
Forum: Electrical Tech 12-20-2010, 02:18 AM
Replies: 30
Views: 5,093
Posted By Hawkeye59
Re: Battery dead after 4 to 5 day non use of truck

As you most likely saw in my other post I am suspecting alternator being an issue so I will have them change it out while they are under the hood.
Forum: General Tech 12-20-2010, 02:15 AM
Replies: 9
Views: 2,404
Posted By Hawkeye59
Re: Result of improper jumper cable hookup question

Well I gave battery disconnect thing a try and for allot longer than 15-20 minutes. After jumping it starts up fine and runs normal however once I pull the jumper cables and it has to rely on its...
Forum: Electrical Tech 12-19-2010, 10:47 PM
Replies: 30
Views: 5,093
Posted By Hawkeye59
Battery dead after 4 to 5 day non use of truck

Truck was left to me by my father in 2007. I noted right off that if I didn't run it at least every four days max the battery was dead by day five. After some time dealing with this I replaced the...
Forum: General Tech 12-19-2010, 09:41 PM
Replies: 9
Views: 2,404
Posted By Hawkeye59
Result of improper jumper cable hookup question

Having jumped my truck many times I have to kick my own butt for doing this. Tonight I needed to jump my truck once again. However I didn't take the time to get a flashlight to see things as I...
Showing results 1 to 11 of 11