Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Showing results 1 to 25 of 500
Search took 0.05 seconds.
Search: Posts Made By: Bob C. of Indiana
Forum: Electrical Tech 06-16-2019, 11:42 AM
Replies: 6
Views: 142
Posted By Bob C. of Indiana
Re: No Start - PATS or something else?

I bought a new one and repaced it as I stated.
Forum: Electrical Tech 06-16-2019, 01:12 AM
Replies: 6
Views: 142
Posted By Bob C. of Indiana
Re: No Start - PATS or something else?

My 2004 did that,had it towed, to a shop up the street.They reset the inertia switch, fine for awhile and kept it up and I would reset and it would start.I went to Walgreens came out no start,reset...
Forum: General Ford Ranger Discussion 06-07-2019, 01:46 AM
Replies: 7
Views: 249
Posted By Bob C. of Indiana
Re: Slip Yoke "CLUNK"

I had the same problem when I first bought my truck.Here is a link to answers.
http://www.fordrangerforum.com/drivetrain-tech/112307-2004-regular-cab-slip-spine.html
Forum: Electrical Tech 05-31-2019, 11:51 AM
Replies: 14
Views: 329
Posted By Bob C. of Indiana
Re: Turn Signal Issue

Thanks Robert-O,we are getting rare anymore,the World is a changing! :eek:
Forum: Electrical Tech 05-31-2019, 01:18 AM
Replies: 14
Views: 329
Posted By Bob C. of Indiana
Re: Turn Signal Issue

Hey Matt,I don't come around very often,stopped fiddling with the truck,just maintenance and driving it.I read the new posts daily still. I bet your sick of rain and flooding where your at,hope your...
Forum: Electrical Tech 05-30-2019, 06:38 AM
Replies: 14
Views: 329
Posted By Bob C. of Indiana
Re: Turn Signal Issue

Thought about it, but too much old school! Lol
Forum: Electrical Tech 05-30-2019, 05:47 AM
Replies: 14
Views: 329
Posted By Bob C. of Indiana
Re: Turn Signal Issue

I'm replacing the multi-function switch, if the blinker don't cure it. Since it blinks with key out and going down the road that's what's steering me to the blinker. Another possibility is the wiring...
Forum: Electrical Tech 05-30-2019, 02:37 AM
Replies: 14
Views: 329
Posted By Bob C. of Indiana
Re: Turn Signal Issue

The flasher is actually located behind the OBD reader plug in on my 2004. Next question why is it clicking randomly with ignition off and going down the road with the tiurn signal off? Is it because...
Forum: Electrical Tech 05-29-2019, 06:08 PM
Replies: 14
Views: 329
Posted By Bob C. of Indiana
Re: Turn Signal Issue

Anybody out there?
Forum: Electrical Tech 05-29-2019, 05:30 AM
Replies: 14
Views: 329
Posted By Bob C. of Indiana
Re: Turn Signal Issue

2004 3.0 Edge Less than a !00,000.
Forum: Electrical Tech 05-29-2019, 02:07 AM
Replies: 14
Views: 329
Posted By Bob C. of Indiana
Forum: Electrical Tech 05-28-2019, 02:58 PM
Replies: 14
Views: 329
Posted By Bob C. of Indiana
Turn Signal Issue

I'll start at the beginning. My turn signal flasher clicks in my garage with the key out and off. It clicks sometimes going down the road without the signal being on. I searched the issue and came up...
Forum: Drivetrain Tech 04-21-2019, 10:16 AM
Replies: 7
Views: 271
Posted By Bob C. of Indiana
Re: Split CV Boots

Thanks Grev!
Forum: Drivetrain Tech 04-14-2019, 01:08 PM
Replies: 7
Views: 271
Posted By Bob C. of Indiana
Re: Split CV Boots

Thanks,that's what I was a thinking. Never seen yet, a glue that sooner or later didn't fail.
Forum: Drivetrain Tech 04-14-2019, 01:00 AM
Replies: 7
Views: 271
Posted By Bob C. of Indiana
Split CV Boots

My front CV boots are ripped and damaged and have seen the glue clamp on replacements.Has anyone bought a pair and tried them and do they work or just another waste of money.Your opinion? Thanks
Forum: Interior Parts 03-24-2019, 12:41 PM
Replies: 9
Views: 666
Posted By Bob C. of Indiana
Re: 2002 Ranger FX4 Level 2 Interior door panels

You might note that they are for power windows.
Forum: Interior Parts 03-23-2019, 12:57 AM
Replies: 9
Views: 666
Posted By Bob C. of Indiana
Re: 2002 Ranger FX4 Level 2 Interior door panels

Very interested if they are in good shape.Private message me some pictures.Thanks
Forum: Off Topic 03-22-2019, 01:09 AM
Replies: 6
Views: 414
Posted By Bob C. of Indiana
Re: The USA Is The Unhappiest It's Ever Been

Being close to 70 years old,every morning I wake up I'm happy! :D
Forum: Off Topic 02-25-2019, 03:38 PM
Replies: 2
Views: 420
Posted By Bob C. of Indiana
Re: What was your first vehicle you owned?

55 Chevy 210,2 door post. had it painted $125,new vinyl roll and tuck seat covers,door side panels,black carpet,chrome reverse wheels,all ready for the 327 transplant and a guy in a 2 day old GTX 440...
Forum: Off Topic 02-25-2019, 03:15 PM
Replies: 1,584
Views: 106,086
Posted By Bob C. of Indiana
Re: Build Thread - Logan's 2003 Mach 1

I used to drink Miller Genuine Draft Light and run out,12 pack,then a buddy would offer me a Coors Light because he drove and was a sipper. I thought damn these are tasty and have been drinking...
Forum: Off Topic 02-25-2019, 02:51 PM
Replies: 1,584
Views: 106,086
Posted By Bob C. of Indiana
Re: Build Thread - Logan's 2003 Mach 1

Thanks Matt,all is good bud.Have no problems so far,at my age it can all change in a New York minute. Still love my Ranger and still a garage queen,keeping it perfect hopefully for my great son,who...
Forum: Off Topic 02-25-2019, 12:36 PM
Replies: 1,584
Views: 106,086
Posted By Bob C. of Indiana
Re: Build Thread - Logan's 2003 Mach 1

No sweat Matt,you got bigger fish to fry! :D
Forum: Off Topic 02-25-2019, 06:32 AM
Replies: 1,584
Views: 106,086
Posted By Bob C. of Indiana
Re: Build Thread - Logan's 2003 Mach 1

Matt I feel lucky, I'm turning 70, no major health issues.Watching lots of my buddies suffering and dying. All in all,life is good! I read your posts and assume your doing good. Thanks, Bud!
Forum: Off Topic 02-25-2019, 03:05 AM
Replies: 1,584
Views: 106,086
Posted By Bob C. of Indiana
Re: Build Thread - Logan's 2003 Mach 1

Hey Matt,still checking in daily.Stayed away during the blue screen episode! Gave up adding to Ol'Blackie since I got her where I wanted it.Only had a couple of issues since I bought her. I have only...
Forum: General Tech 02-15-2019, 07:37 AM
Replies: 31
Views: 1,362
Posted By Bob C. of Indiana
Re: Starter spins but not engageing flywheel,No Start?

Took the Ranger to Ford today and had inertia switch replaced. Believe it or not, the switch was the same price as online,I was shocked.I believe they are all aftermarket now,not OEM. Thanks all, for...
Showing results 1 to 25 of 500