Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Showing results 1 to 6 of 6
Search took 0.00 seconds.
Search: Posts Made By: chrissortman
Forum: Electrical Tech 01-22-2013, 01:18 PM
Replies: 13
Views: 1,036
Posted By chrissortman
Re: HIDs and Subwoofer with Amp

Are your HIDs Hi/Lo or are they just low?
Forum: Electrical Tech 01-22-2013, 11:55 AM
Replies: 13
Views: 1,036
Posted By chrissortman
Re: HIDs and Subwoofer with Amp

Did you have the stock alternator?
Forum: Electrical Tech 01-22-2013, 09:31 AM
Replies: 13
Views: 1,036
Posted By chrissortman
Re: HIDs and Subwoofer with Amp

Thank you.



I'm just curious as to if anyone has this set up to see how they did it/how well it works or any issues they have if any.
Forum: Electrical Tech 01-22-2013, 09:23 AM
Replies: 13
Views: 1,036
Posted By chrissortman
Re: HIDs and Subwoofer with Amp

So even running the HIDs directly to the battery through a harness and having an amp hooked up it should be fine?
Forum: Electrical Tech 01-22-2013, 09:20 AM
Replies: 13
Views: 1,036
Posted By chrissortman
Re: HIDs and Subwoofer with Amp

Probably just a 10" sub and either a 600w or 1000w amp, no higher than that though.

----------

Well, I know that they require less power, but at startup don't they tend to draw in high wattage...
Forum: Electrical Tech 01-22-2013, 09:07 AM
Replies: 13
Views: 1,036
Posted By chrissortman
HIDs and Subwoofer with Amp

Does anyone have a subwoofer and HIDs in their Ranger? I am just trying to see if it would be using too much of the battery power to have both HIDs hooked up with the harness and a subwoofer with an...
Showing results 1 to 6 of 6