Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Showing results 1 to 7 of 7
Search took 0.00 seconds.
Search: Posts Made By: kade.anderson18
Forum: Drivetrain Tech 09-01-2016, 10:13 PM
Replies: 2
Views: 394
Posted By kade.anderson18
Best place to buy a new transmission?

What is the best place to get a used transmission? i have a 2004 ford ranger edge v6 2wd. any place where i can get one for somewhat cheap?
Forum: Interior Tech 09-01-2016, 03:32 PM
Replies: 1
Views: 536
Posted By kade.anderson18
Bucket Seat modification

So for these seats I found on eBay ......http://m.ebay.com/itm/JDM-BR-Style-Blk-Red-Suede-Reclinable-Racing-Bucket-Seats-w-Sliders-Kit-Pair-V12-/371649975134?nav=SEARCH

What mounting brackets...
Forum: Drivetrain Tech 08-31-2016, 06:34 AM
Replies: 11
Views: 731
Posted By kade.anderson18
clean pinkish red color

clean pinkish red color
Forum: Drivetrain Tech 08-30-2016, 09:24 PM
Replies: 11
Views: 731
Posted By kade.anderson18
still a tough one because I do not know what's...

still a tough one because I do not know what's going on. Now when putting it into 1st it goes a few miles per hour (barely moving) but I wants to move. Still have to give it has to do this. Drive...
Forum: Drivetrain Tech 08-30-2016, 05:44 PM
Replies: 11
Views: 731
Posted By kade.anderson18
no check engine light or OD light only ABS light...

no check engine light or OD light only ABS light car runs in second but doesn't shift past third gear in second I have to switch it to drive to shift through all gears
Forum: Drivetrain Tech 08-30-2016, 11:08 AM
Replies: 11
Views: 731
Posted By kade.anderson18
Re: 1st gear doesn't work

Yes reverse works
Forum: Drivetrain Tech 08-29-2016, 08:09 PM
Replies: 11
Views: 731
Posted By kade.anderson18
1st gear doesn't work

Soooooooo..... I have a 2004 ford ranger edge 2wd automatic transmission with 150,000 miles and Drive nor first gear work. the reason drive doesn't work is because obviously the car has to start in...
Showing results 1 to 7 of 7