Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Showing results 1 to 9 of 9
Search took 0.02 seconds.
Search: Posts Made By: Athee
Forum: 3.0 Vulcan Tech 03-29-2015, 06:35 PM
Replies: 11
Views: 830
Posted By Athee
Re: Crossed Plug Wires

No, just the plugs.
Forum: 3.0 Vulcan Tech 03-29-2015, 06:28 PM
Replies: 11
Views: 830
Posted By Athee
Re: Crossed Plug Wires

New battery and alternator in the last two months. I think my timing may have gotten all out of sync.
Forum: 3.0 Vulcan Tech 03-29-2015, 06:23 PM
Replies: 11
Views: 830
Posted By Athee
Re: Crossed Plug Wires

I have rechecked, and tried the reset. Engine will still not turn over and starter sounds as though it is working.
Forum: 3.0 Vulcan Tech 03-29-2015, 05:47 PM
Replies: 11
Views: 830
Posted By Athee
Crossed Plug Wires

I am embarassed to post this but I accidentaly crossed plug wires when I installed new plugs. When I started my truck (2006 Ford Ranger STX 3.0 VIN U) the engine spit and sputtered and I knew...
Forum: General Ford Ranger Discussion 02-07-2010, 11:09 AM
Replies: 12
Views: 1,392
Posted By Athee
No leaks, and coil packs been changed twice!!...

No leaks, and coil packs been changed twice!! Also, new plugs and wires in addition to many other things. Weak valve spring!
Forum: General Ford Ranger Discussion 02-06-2010, 08:08 AM
Replies: 12
Views: 1,392
Posted By Athee
For any of you who come across this problem,...

For any of you who come across this problem, after two Ford Dealerships, and $3600 for nearly every new part you can think of, my problem has finally been repaired. As it turns out I had a weak valve...
Forum: General Ford Ranger Discussion 12-06-2009, 09:24 AM
Replies: 12
Views: 1,392
Posted By Athee
Ford thoroughly tested all components of my...

Ford thoroughly tested all components of my truck. An engineer was there from the factory and they determined I need a new Power Train Control Module. For a mere $688.00 and a week to get the part...
Forum: General Ford Ranger Discussion 12-03-2009, 12:56 PM
Replies: 12
Views: 1,392
Posted By Athee
No, I have never had them replaced. Truck runs...

No, I have never had them replaced. Truck runs great while driving but idles rough and the engine light starts blinking if I let it sit for a few seconds. Don't have any loss of power either.
Forum: General Ford Ranger Discussion 12-03-2009, 12:15 PM
Replies: 12
Views: 1,392
Posted By Athee
Unhappy Frustrated To the MAX!

I have a 2006 Ranger 3.0. I use this vehicle as a Pilot Car. To date I have 168,000 miles. At 95,000 the valves needed replacing (because of cylinder 1 misfire.) I did have low compression. Got this...
Showing results 1 to 9 of 9