Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Showing results 1 to 7 of 7
Search took 0.04 seconds.
Search: Posts Made By: firerescue47906
Forum: 2.9 Liter Tech 01-22-2012, 09:27 AM
Replies: 27
Views: 2,661
Posted By firerescue47906
Re: Please Help. ASAP!

oh ok so it doesn't make the water go in a certain direction in the cooling system, maybe I did use that
Forum: 2.9 Liter Tech 01-21-2012, 09:00 PM
Replies: 27
Views: 2,661
Posted By firerescue47906
Re: Please Help. ASAP!

Hmm. I don't remember ever putting anything in to prevent backflow.

Attach Back-Flow Preventer Coupler to Flushing TEE and water supply line (black end to tee, Yellow end to garden hose).
Forum: 2.9 Liter Tech 01-21-2012, 08:50 PM
Replies: 27
Views: 2,661
Posted By firerescue47906
Re: Please Help. ASAP!

No it doesn't, I would take a pic but its outside and its 19 degrees and dark. Maybe I did not flush it properly. I put the garden hose connector in the heater hose and took the cap off the radiator...
Forum: 2.9 Liter Tech 01-21-2012, 07:24 PM
Replies: 27
Views: 2,661
Posted By firerescue47906
Re: Please Help. ASAP!

There is pressure, I felt the cap and it was cold so I loosened it to the safety catch and coolant sprayed everywhere. I took the cap off and idled the truck to see if I could see coolant flowing and...
Forum: 2.9 Liter Tech 01-21-2012, 07:14 PM
Replies: 27
Views: 2,661
Posted By firerescue47906
Re: Please Help. ASAP!

The engine is overheating, the coolant in the radiator seems not to get hot.
Forum: 2.9 Liter Tech 01-21-2012, 04:19 PM
Replies: 27
Views: 2,661
Posted By firerescue47906
Re: Please Help. ASAP!

Both... I replaced the temp sensor for the gauge. There is pressure in the radiator but it don't seem to be getting hot...
Forum: 2.9 Liter Tech 01-21-2012, 03:35 PM
Replies: 27
Views: 2,661
Posted By firerescue47906
Please Help. ASAP!

I have an '88 ranger 2.9 4x4, I cannot keep it from over heating, I have replaced the water pump, thermostat, I have flushed the radiator, I have tried running it with no thermostat, I have installed...
Showing results 1 to 7 of 7