Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Showing results 1 to 17 of 17
Search took 0.00 seconds.
Search: Posts Made By: glindy
Forum: Exterior Tech 06-09-2012, 03:40 PM
Replies: 2
Views: 1,610
Posted By glindy
Re: Ranger bed interchange

Sounds good thanks, now I have to drive 90 mi to get it.
Ins co stuck it to me and totaled truck,gave me ~3000 less than KBB value, then charged me 4x what salvage yards offered me on it to keep....
Forum: Exterior Tech 06-09-2012, 03:25 PM
Replies: 2
Views: 1,610
Posted By glindy
Ranger bed interchange

Will 1996 6ft bed reg cab work on 2002 truck ext cab? The color looks the same bright red or vermillion
Forum: 3.0 Vulcan Tech 05-11-2012, 11:58 PM
Replies: 17
Views: 4,571
Posted By glindy
Re: 2002 ranger 3.0 aod engine? bucking

Follow up. replaced front cat and one oxy. it ran great.

Then woke up the other morning to find the left rear smashed in,bent wheel/tire,screwed up tranny shifter,rear cab door sprung all the...
Forum: 3.0 Vulcan Tech 04-15-2012, 11:00 PM
Replies: 38
Views: 6,066
Posted By glindy
Re: Struggling to go past 60mph.

I do know that after replacing the front cats my 3.0 had no lack of power and easily accelerated to 80 with no hesitation
Forum: 3.0 Vulcan Tech 04-14-2012, 07:16 PM
Replies: 38
Views: 6,066
Posted By glindy
Re: Struggling to go past 60mph.

You need to check back pressure on exhaust for a clogged cat. Or pull O2 sensor/loosen manifold and see if it smooths engine out.
Forum: 3.0 Vulcan Tech 04-12-2012, 12:44 PM
Replies: 17
Views: 4,571
Posted By glindy
Re: 2002 ranger 3.0 aod engine? bucking

Replaced front cat and a new O2. No more misfires/codes,good response,full throttle with no bucking on highway. Lots of folks need to check cats,instead of replacing all the sensors,etc.
Forum: 3.0 Vulcan Tech 04-12-2012, 12:39 PM
Replies: 5
Views: 1,676
Posted By glindy
Re: 2002 3.0 temp gauge issue

Actually it is a factory two blade sensor on 1 wire. I went to a good ford dealer and they had multiple sensors for and 02,took the old one and matched the numbers up. Installed it and guess what,it...
Forum: 3.0 Vulcan Tech 04-12-2012, 10:05 AM
Replies: 5
Views: 1,676
Posted By glindy
Re: 2002 3.0 temp gauge issue

Actually it may be a different issue. And I am not alone on this after sensor replacement with temp gauge failure.

I got another new 2blade sensor from Autozone and put it in hot water. It had...
Forum: 3.0 Vulcan Tech 04-12-2012, 05:56 AM
Replies: 5
Views: 1,676
Posted By glindy
Re: 2002 3.0 temp gauge issue

Think I have answer.
Put safety pin in harness and grounded out to bat,turned key on and gauge needled pegged.
So, my bet is that my new Autozone Mexican made sensor is junk.
Forum: 3.0 Vulcan Tech 04-11-2012, 06:47 PM
Replies: 5
Views: 1,676
Posted By glindy
2002 3.0 temp gauge issue

Dash temp gauge functioned properly at first,found sensor housing was cracked and wired together so replaced with new sender. Now temp gauge will not move?
Checked voltage at 1 wire gauge and it is...
Forum: 3.0 Vulcan Tech 04-04-2012, 07:19 PM
Replies: 17
Views: 4,571
Posted By glindy
Re: 2002 ranger 3.0 aod engine? bucking

Think I located it.
After doing the coil pac,good noid light,fuel pressure,compression,valve springs,Maf voltage, etc pretty well narrowed itt down to a vacuum leak,OXY,cat.

Did a vaccuum test...
Forum: 3.0 Vulcan Tech 04-03-2012, 06:47 PM
Replies: 17
Views: 4,571
Posted By glindy
Re: 2002 ranger 3.0 aod engine? bucking

the 2002 ranger has no egr valve.
only the 2.3 and 4.0 have them in 02
Forum: 3.0 Vulcan Tech 04-01-2012, 07:31 PM
Replies: 17
Views: 4,571
Posted By glindy
Re: 2002 ranger 3.0 aod engine? bucking

Next step,
Finally located noid light set and checked right bank,had to use gm style light as ford tbi did not fit harness. They all had a signal,not sure if it was timed right but they all did...
Forum: 3.0 Vulcan Tech 03-31-2012, 06:43 PM
Replies: 17
Views: 4,571
Posted By glindy
Re: 2002 ranger 3.0 aod engine? bucking

Nick,
I used my scan tool to reset the ecm,won't this do the same? Anyway the misfires on 5/6 came back as well as lean bank2 code. So I went ahead and picked up a new coil as spark looked weak when...
Forum: 3.0 Vulcan Tech 03-30-2012, 06:11 PM
Replies: 17
Views: 4,571
Posted By glindy
Re: 2002 ranger 3.0 aod engine? bucking

OK,
I did oil change and changed wires and new autolite plugs,it still runs bad and shows PO305 #5 misfire. swapped plugs,still missing.swapped wires still missing.
Installed new cam...
Forum: 3.0 Vulcan Tech 03-28-2012, 09:07 PM
Replies: 17
Views: 4,571
Posted By glindy
Re: 2002 ranger 3.0 aod engine? bucking

Thanks,
I just stuck my head under the hood and started playin,the fan clutch was locked solid. Only 60 bucks,but getting it off was a bear,the tools they loaned me did nothing,as it has a recessed...
Forum: 3.0 Vulcan Tech 03-27-2012, 10:14 PM
Replies: 17
Views: 4,571
Posted By glindy
2002 ranger 3.0 aod engine? bucking

I just purchased a used 02 xcab 3.0 at as is and it has some issues. The truck has 2xx,xxx mi but the engine seems to run well,except when it exceeds 3500+ rpm, then either in OD,third,or dropped in...
Showing results 1 to 17 of 17