Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Showing results 1 to 25 of 25
Search took 0.00 seconds.
Search: Posts Made By: Danny7
Forum: 2.9 Liter Tech 09-25-2013, 03:57 PM
Replies: 13
Views: 1,769
Posted By Danny7
Re: Spinning wheel stud. Need help

I am going to try a torch tomorrow. The nut splitter won't work the nut is recessed in the rim.
Forum: 2.9 Liter Tech 09-25-2013, 03:00 PM
Replies: 13
Views: 1,769
Posted By Danny7
Re: Spinning wheel stud. Need help

That is what I have been using. I even tried pulling on a side and they are to stuck.
Forum: 2.9 Liter Tech 09-25-2013, 01:53 PM
Replies: 13
Views: 1,769
Posted By Danny7
Spinning wheel stud. Need help

I have 3 spinning studs on my wheel. They are loose enough to wiggle. The lug nuts must have loosened and got stuck on the stud. What do yall think the best approach?
Forum: 2.9 Liter Tech 07-20-2013, 11:17 AM
Replies: 0
Views: 1,612
Posted By Danny7
Dies when put in gear

I now have a new problem with my truck. Randomly at a stop light my truck died. I put it in park and it started fine but as soon as I put it in gear (R,1,2,D, and OD) it stalls out. Sounds like...
Forum: 2.9 Liter Tech 07-14-2013, 04:08 PM
Replies: 15
Views: 1,942
Posted By Danny7
Re: Won't start when warm. Already relocated TFI

So I finally had time to sit and work on my truck. I had a engine hot no start problem. There wasn't any spark whenever It was hot. I got a new tfi and a new coil thinking maybe it was the problem....
Forum: 2.9 Liter Tech 06-19-2013, 06:18 PM
Replies: 15
Views: 1,942
Posted By Danny7
Re: Won't start when warm. Already relocated TFI

Haven't looked at the codes yet but I got stuck the other day after going to the store. Truck would crank but would not start. I changed the tfi right there to a working one and it still did not...
Forum: 2.9 Liter Tech 06-19-2013, 06:14 PM
Replies: 10
Views: 2,627
Posted By Danny7
Re: No sound of Fuel Pump, not starting

You said your fuel pump doesn't run? So when you turn the key it doesn't prime? To see I it works take a paper clip and go to the fuel relay. And jump two of the wires. Forgot which two but after...
Forum: 2.9 Liter Tech 06-13-2013, 09:15 PM
Replies: 17
Views: 2,886
Posted By Danny7
Re: pothole has killed my truck, i need help?

When you turn your key does your fuel pump prime? I had the same problem. Mine wouldn't prime. The ground wire under my battery popes of and I didn't did it for a number of days. It drove me insane....
Forum: 2.9 Liter Tech 06-13-2013, 12:50 PM
Replies: 15
Views: 1,942
Posted By Danny7
Re: Won't start when warm. Already relocated TFI

New tfi didn't do anything. I put the old one on so I don't ruin the new one completely. Something else has to be wrong. Could it be the pip. I have to look at the stores codes yet too.
Forum: 2.9 Liter Tech 06-12-2013, 04:51 PM
Replies: 15
Views: 1,942
Posted By Danny7
Re: Won't start when warm. Already relocated TFI

Changed the coil. Didn't work. Bought a new tfi. Just installed it. Haven't tried repeated the problem yet. But I felt the bak of the tfi when it was running and is it supposed to get really hot....
Forum: 2.9 Liter Tech 06-02-2013, 07:25 PM
Replies: 15
Views: 1,942
Posted By Danny7
Re: Won't start when warm. Already relocated TFI

So the other day my truck wouldn't start because it was warm. I connected a good spark plug on the wire coming from the coil. There was no spark. So that rules out timing. I was reading about those...
Forum: 2.9 Liter Tech 05-29-2013, 11:53 AM
Replies: 15
Views: 1,942
Posted By Danny7
Re: Won't start when warm. Already relocated TFI

I will pull out the handy dandy timing light and make sure it is timed correctly. Then we will go from there.
Forum: 2.9 Liter Tech 05-29-2013, 11:20 AM
Replies: 15
Views: 1,942
Posted By Danny7
Re: Won't start when warm. Already relocated TFI

Truck is running fine so the timing can't be off. Is the coil the only other possibility?

----------

I have to do a spark test straight off the coil after it doesn't want to start. Maybe that...
Forum: 2.9 Liter Tech 05-24-2013, 11:19 PM
Replies: 15
Views: 1,942
Posted By Danny7
Re: Won't start when warm. Already relocated TFI

87 ranger. I already relocated the tfi so it wouldn't heat up. After it still doesn't like to start when it is warm. It just cranks over. Good fuel pressure. Sparks when cooled off. Can the coil be...
Forum: 2.9 Liter Tech 05-24-2013, 08:16 PM
Replies: 15
Views: 1,942
Posted By Danny7
Won't start when warm. Already relocated TFI

Hello all.

Truck has been running fine until it started getting warm out again. I relocated the tfi to the fender already. Truck will not start when warm.. What could this be? It starts when it...
Forum: 2.9 Liter Tech 04-22-2013, 07:22 PM
Replies: 25
Views: 2,244
Posted By Danny7
Re: Bad relay?

So I was checking grounds and I saw two that we connected correctly. I was looking under the battery and the guy who owed the truck before me spliced a new ground wire in and it snapped to where you...
Forum: 2.9 Liter Tech 04-22-2013, 03:41 PM
Replies: 25
Views: 2,244
Posted By Danny7
Re: Bad relay?

Gas is pumping. There is pressure in the rail. Just not getting into cylinders. Something is telling the injectors not to fire. Hence why I think it may be the Ecu or a bad ground.

----------
...
Forum: 2.9 Liter Tech 04-22-2013, 01:44 PM
Replies: 25
Views: 2,244
Posted By Danny7
Re: Bad relay?

The reason why I think it is the Ecu is because the pump doesn't run at all when I turn the key to on or when cranking. Why would the MAP sensor prevent the fuel pump from running? I am definitely...
Forum: 2.9 Liter Tech 04-22-2013, 11:28 AM
Replies: 25
Views: 2,244
Posted By Danny7
Re: Bad relay?

Alright I am going to repost all the symptoms.

-turn key doesn't prime pump
-truck has full power, cranks over but doesn't start
-jumped the fuel pump and it runs.
-tries starting truck with...
Forum: 2.9 Liter Tech 04-21-2013, 09:57 AM
Replies: 25
Views: 2,244
Posted By Danny7
Re: Bad relay?

It has pressure and it is a daily driver. I just recently filled up. Could it be the Ecu?
Forum: 2.9 Liter Tech 04-20-2013, 03:13 PM
Replies: 25
Views: 2,244
Posted By Danny7
Re: Bad relay?

Just shot starting fluid in the intake and it sputters. So there IS spark.
Forum: 2.9 Liter Tech 04-20-2013, 02:24 PM
Replies: 25
Views: 2,244
Posted By Danny7
Re: Bad relay?

So I jumped the fuel pump And it is good. Tried starting the truck with it jumped and it wouldn't start. It isn't getting spark it seems like. There is power to the coil too. Maybe the tfi could be...
Forum: 2.9 Liter Tech 04-19-2013, 12:45 PM
Replies: 25
Views: 2,244
Posted By Danny7
Re: Bad relay?

Alright I will take a look. Got a new relay just for the hell of it and it isn't the relay.
Forum: 2.9 Liter Tech 04-19-2013, 10:59 AM
Replies: 25
Views: 2,244
Posted By Danny7
Re: Bad relay?

Which slot/wire in the diagnostics connector is it?
Forum: 2.9 Liter Tech 04-18-2013, 09:21 PM
Replies: 25
Views: 2,244
Posted By Danny7
Bad relay?

Hello all. I was leavin work today ad I was accelerating in the parking lot my truck all I a sudden died. Tried starting it and cranks fine. Fuel pump doesn't purge when key is turned. Can a relay...
Showing results 1 to 25 of 25