Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Showing results 1 to 4 of 4
Search took 0.00 seconds.
Search: Posts Made By: jonfal
Forum: General Tech 10-21-2010, 12:27 PM
Replies: 6
Views: 4,007
Posted By jonfal
Re: Unique A/C problem

Well, the grounds look fine, and they were tight. However, something popped into my head, and I decided to swap the relay for the AC/Clutch with the Fog Lamp. Long story, but my windshield wiper...
Forum: General Tech 10-21-2010, 10:36 AM
Replies: 6
Views: 4,007
Posted By jonfal
Re: Unique A/C problem

Rwenzing, thanks for that info. I had already checked and replaced both fuses, but checked them again just to make sure they were still OK.

As far as checking the grounds, I made need some help...
Forum: General Tech 10-21-2010, 08:20 AM
Replies: 6
Views: 4,007
Posted By jonfal
Re: Unique A/C problem

I certainly tried, and had 2 people taking a look at it as well (including one that grew with a dad as a mechanic I believe).

At this point I'm just trying to find out if the ECM could indeed be...
Forum: General Tech 10-21-2010, 07:46 AM
Replies: 6
Views: 4,007
Posted By jonfal
Unique A/C problem

2005 Ford Ranger 4.0 XLT 4WD - 130k miles

6 months ago, I had the compressor replaced when the A/C clutch went after trying a "band-aid" that worked for all of 1 day. A/C has been working fine,...
Showing results 1 to 4 of 4