Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Showing results 1 to 9 of 9
Search took 0.00 seconds.
Search: Posts Made By: OldTruck
Forum: General Ford Ranger Discussion 11-18-2009, 09:26 PM
Replies: 42
Views: 2,320
Posted By OldTruck
Straight drive?

What do you mean by "straight drive"?
Forum: Electrical Tech 11-14-2009, 01:16 PM
Replies: 3
Views: 1,676
Posted By OldTruck
A hot rod it certainly was not! I tried once...

A hot rod it certainly was not!

I tried once when it was new to get it up to 90 mph, but it would
not go over 85, even down hill. Later I read somewhere that Ford had
a speed limiter in it due...
Forum: Electrical Tech 11-11-2009, 09:23 AM
Replies: 3
Views: 1,676
Posted By OldTruck
Question Replacement computer chips?

Well, I have my '88 Ranger running again, after setting in my driveway
for 4 months. During that time I was forced to drive my wife's '09
Mazda5 which also has a 2.3L engine.

The Mazda5 makes...
Forum: General Ford Ranger Discussion 11-10-2009, 05:38 PM
Replies: 263
Views: 30,689
Posted By OldTruck
Cool My 1988 Ranger Supercab, 2.3L 5spd has 177K miles...

My 1988 Ranger Supercab, 2.3L 5spd has 177K miles on it.
Forum: 4-Cylinder Tech 11-09-2009, 05:35 PM
Replies: 13
Views: 3,277
Posted By OldTruck
Red face Oil pressure problem update

I decided I didn't want to do the job lying on my back in my driveway,
so I finally had the truck towed back to the repair shop. They found
they could get to the oil pump without pulling the...
Forum: 4-Cylinder Tech 08-24-2009, 10:06 PM
Replies: 13
Views: 3,277
Posted By OldTruck
Odd that you say that about Fram filters. I used...

Odd that you say that about Fram filters. I used fram filters for most of the
178K miles on my truck, and had no problems until now. If Fram filters were
bad, you'd think I would have had problems...
Forum: 4-Cylinder Tech 07-21-2009, 02:06 PM
Replies: 13
Views: 3,277
Posted By OldTruck
Well, I couldn't get this forum to work last...

Well, I couldn't get this forum to work last week. Now it seems to be OK.

Anyway, the oil level is slightly above full level. The gasket I used was an
aftermarket rubber gasket with instructions...
Forum: 4-Cylinder Tech 07-18-2009, 07:46 AM
Replies: 13
Views: 3,277
Posted By OldTruck
The mechanic that checked it out said he attached...

The mechanic that checked it out said he attached a pressure gage and
found at idle it held about 40 psi, but when the rpm was increased the
pressure dropped of to about 15 psi.

This problem...
Forum: 4-Cylinder Tech 07-17-2009, 06:50 PM
Replies: 13
Views: 3,277
Posted By OldTruck
Question Oil light comes on above idle

I have a problem that someone may have dealt with or heard of before. Here
is a description:

My 1988 Ranger Super Cab, 2X4, 2.3L EFI, 5 spd manual, 177K miles.

After starting, the oil light...
Showing results 1 to 9 of 9