Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Showing results 1 to 7 of 7
Search took 0.00 seconds.
Search: Posts Made By: 4.0rangermike
Forum: Electrical Tech 01-26-2015, 06:03 AM
Replies: 10
Views: 1,052
Posted By 4.0rangermike
Re: 98 4.0 starting/stalling problems

It was the PCM they replaced. Since the last post my fuel pump died. I guess it fried out due to it being turned on and off so many times when the starter relay was clicking. It was only three years...
Forum: Electrical Tech 01-07-2015, 10:04 AM
Replies: 10
Views: 1,052
Posted By 4.0rangermike
Re: 98 4.0 starting/stalling problems

Okay I will try that. I think something is wrong with the electrical because after I got it back from my mechanic when he changed the EGR I had engine noise in the radio. Sounded like a loud whistle...
Forum: Electrical Tech 01-06-2015, 02:02 PM
Replies: 10
Views: 1,052
Posted By 4.0rangermike
Re: 98 4.0 starting/stalling problems

So the mechanic had the same problem with the "No Link" on their code reader. The solution was to replace the on board computer. It worked fine for a week and started stalling out again. So I...
Forum: Electrical Tech 11-26-2014, 11:14 AM
Replies: 10
Views: 1,052
Posted By 4.0rangermike
Re: 98 4.0 starting/stalling problems

So it was working today fine again then stalled out on my way to class. This time I took out my code reader and plugged it in. Code reader said "No Link". Then it started working fine again code...
Forum: Electrical Tech 11-26-2014, 06:08 AM
Replies: 10
Views: 1,052
Posted By 4.0rangermike
Re: 98 4.0 starting/stalling problems

So my battery checked out good. Charged it up anyway. Went to autozone and 0 codes. I bought a code reader so hopefully the next time this starts to happen I will be able to pull a code right away....
Forum: Electrical Tech 11-24-2014, 02:44 PM
Replies: 10
Views: 1,052
Posted By 4.0rangermike
Re: 98 4.0 starting/stalling problems

It cranks fine it just doesn't turn over. The battery tests fine too. the problem with the codes is that the CEL goes off once it starts up again or rests for a little bit. Unfortunately I do not...
Forum: Electrical Tech 11-24-2014, 01:31 PM
Replies: 10
Views: 1,052
Posted By 4.0rangermike
98 4.0 starting/stalling problems

1998 4.0 RWD Manual

Okay this problem has been intermittent for the last two weeks. I believe it is electrical.

What happens is sometimes I will turn the key into the starting position and the...
Showing results 1 to 7 of 7