Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Showing results 1 to 8 of 8
Search took 0.03 seconds.
Search: Posts Made By: dangerranger704
Forum: Electrical Tech 04-14-2015, 06:54 PM
Replies: 1
Views: 903
Posted By dangerranger704
Re: Voltage to headlights but no light

Turned out to be bad MFS, the connector had melted by what I believe to be low beam output wire, picked up a new one replaced the switch and connector and works like new! Long story short the high...
Forum: 2.9 Liter Tech 04-11-2015, 05:42 PM
Replies: 8
Views: 5,757
Posted By dangerranger704
Re: 1988 ranger 2.9 rough idle, strong gas smell and engine code 63

Even though this is super late it did turn out to be a faulty fuel pressure regulator spitting fuel into the vacuum lines. really simple to check and made me face palm hard haha!
Forum: Electrical Tech 04-11-2015, 05:39 PM
Replies: 1
Views: 903
Posted By dangerranger704
Voltage to headlights but no light

Been having some electrical problems for my 88 ranger XLT blowing a few fuses due to a short behind the stereo(now fixed). But the headlights had been acting up on me lately flickering every once in...
Forum: Wheels and Tires 02-24-2014, 06:20 PM
Replies: 0
Views: 622
Posted By dangerranger704
88 Ranger 2wd unlifted help with new wheels and tires!

I am looking into purchasing new wheels and tires for my 88 ranger but cant seem to find the info on the older rangers. I currently have the stock 14x6 wheels on my 88 and am looking to purchase new...
Forum: 2.9 Liter Tech 11-07-2013, 07:11 PM
Replies: 8
Views: 5,757
Posted By dangerranger704
It was key on engine off and I believe it was...

It was key on engine off and I believe it was just faulty parts one was coming apart at the seams when I opened it and the other read 0 when I checked the resistance with a multimeter as the OEM had...
Forum: 2.9 Liter Tech 11-07-2013, 01:58 PM
Replies: 8
Views: 5,757
Posted By dangerranger704
Re: 1988 ranger 2.9 rough idle, strong gas smell and engine code 63

Well you might be right about the tps. i think i might be getting faulty parts from auto zone as most seem to be broken out of the box... ill look into resetting the stop screw, and getting another...
Forum: 2.9 Liter Tech 11-06-2013, 09:28 PM
Replies: 8
Views: 5,757
Posted By dangerranger704
Re: 1988 ranger 2.9 rough idle, strong gas smell and engine code 63

well the reference voltage is around 5 volts but the tps is sending a steady 4.6-4.8 at idle and wot although i may be testing the wrong wires... and i do believe my buddy screwed with the stop screw...
Forum: 2.9 Liter Tech 11-04-2013, 03:33 PM
Replies: 8
Views: 5,757
Posted By dangerranger704
Exclamation 1988 ranger 2.9 rough idle, strong gas smell and engine code 63

Ok ive exhausted all the threads and have been searching for a solution for damn near a year now. my ranger runs very rough at idle around 900 to 1200 rpm range in drive and 1500 in park. It dies at...
Showing results 1 to 8 of 8