Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Showing results 1 to 9 of 9
Search took 0.00 seconds.
Search: Posts Made By: ctw2349
Forum: Exterior Tech 11-26-2014, 08:51 AM
Replies: 2
Views: 302
Posted By ctw2349
Trying to find black Grille Emblem

I've been trying to find a black grille emblem for my 1996 but I can't find one anywhere. Where should I be looking?
Forum: Introduce Yourself 03-07-2014, 09:15 AM
Replies: 9
Views: 266
Posted By ctw2349
Newbie from GA

What's up. I'm from GA. I live in the Marietta area. I have a 1996 Ranger. It's blacked out on 30s. I take it muddin all the time even though she is a 2wd. I'd like to go to a meet that is close to...
Forum: Suspension Tech 01-15-2014, 11:50 AM
Replies: 2
Views: 431
Posted By ctw2349
Leveling Kit. Help!

I am putting 2" coil spring spacers on the front of my 1996 Ranger. I need to know what kind of shock I will need to put on after I do this. Does it just need to be 2" bigger than the stock one? I...
Forum: Audio / Video 04-22-2012, 07:32 PM
Replies: 10
Views: 2,844
Posted By ctw2349
Re: speakers stopped working

thanks ill check that tomorrow.
Forum: Audio / Video 04-22-2012, 07:16 PM
Replies: 10
Views: 2,844
Posted By ctw2349
Re: speakers stopped working

yes i do have rear speakers and they do not work. and it does not have factory amp
Forum: Audio / Video 04-22-2012, 07:04 PM
Replies: 10
Views: 2,844
Posted By ctw2349
Re: speakers stopped working

yea i did and it is fine.
Forum: Audio / Video 04-22-2012, 07:03 PM
Replies: 26
Views: 2,680
Posted By ctw2349
Re: Head Unit?

Best Buy used to install free if you bought something over $100.00 but now it i $49.99. You do not have to get new speakers but i strongly advise yo to because you will love the difference. if you do...
Forum: Audio / Video 04-22-2012, 06:48 PM
Replies: 10
Views: 2,844
Posted By ctw2349
Re: speakers stopped working

well on that i would either check the wire to the speaker to see if it is connected to it or you could pull out the deck and see if the wire has a good connection. did you use a wire harness?
Forum: Audio / Video 04-22-2012, 06:32 PM
Replies: 10
Views: 2,844
Posted By ctw2349
speakers stopped working

Today I put in 2 10" Kicker SS10 Subs and an 800 watt Kenwood amp into my 1996 Ranger. I wired everything up to my Kenwood KDC-348U headunit I had already installed. When I turned on the radio, the...
Showing results 1 to 9 of 9