Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Showing results 1 to 25 of 127
Search took 0.01 seconds.
Search: Posts Made By: Black04Ranger
Forum: General Ford Ranger Discussion 01-09-2012, 01:58 PM
Replies: 15,998
Views: 798,504
Posted By Black04Ranger
Re: What did you do to your ranger today thread

Installed my new Viper remote starter.... :)
Forum: General Ford Ranger Discussion 05-25-2011, 07:07 AM
Replies: 15,998
Views: 798,504
Posted By Black04Ranger
Re: What did you do to your ranger today thread

So what do you think of these Bull-Gaurd Stainless Steel Tie-Downs? I picked them up on sale last night, originally $35 for a set of 2, on sale for $10 for a set. So for $20 now I have 4 tiedown...
Forum: General Ford Ranger Discussion 05-18-2011, 12:51 PM
Replies: 41
Views: 2,533
Posted By Black04Ranger
Re: OK here's my sad story

hahaha... buying the truck to match the camper.... doh! ;)
Forum: General Ford Ranger Discussion 05-16-2011, 06:42 AM
Replies: 15,998
Views: 798,504
Posted By Black04Ranger
Re: What did you do to your ranger today thread

Well I had on a set of aftermarket fog lights.... but apparently due to the crap-tastic quality of the paint job that they were given, the salt from the winter roads destroyed the paint and broke it...
Forum: General Ford Ranger Discussion 05-12-2011, 11:38 AM
Replies: 15,998
Views: 798,504
Posted By Black04Ranger
Re: What did you do to your ranger today thread

put on a new drivers side sway bar link.... stupid pot hole of death.
Forum: Suspension Tech 05-12-2011, 06:02 AM
Replies: 14
Views: 6,436
Posted By Black04Ranger
Re: HUGE POTHOLE... broke something on suspension

Well guys I just fixed the link last night..... what a LOT of work for such an easy part!

Here's what happened, since the top of the nut got shaved clean off in the break, there was nothing to...
Forum: Suspension Tech 05-11-2011, 11:40 AM
Replies: 14
Views: 6,436
Posted By Black04Ranger
Re: HUGE POTHOLE... broke something on suspension

Awesome man.... really appreciate it.

Oh... but only 25-34ft lbs of torque.... that doesnt seem like much at all... lol
Forum: Suspension Tech 05-11-2011, 11:21 AM
Replies: 14
Views: 6,436
Posted By Black04Ranger
Re: HUGE POTHOLE... broke something on suspension

How do you go about pulling the old one off and putting the new one on? Is it as easy as just breaking the nuts free and pulling it out?

Do you know the specific tightening torque to use on the...
Forum: Suspension Tech 05-11-2011, 10:55 AM
Replies: 14
Views: 6,436
Posted By Black04Ranger
Re: HUGE POTHOLE... broke something on suspension

Is this a part that they usually stock at autozone, or will I need to order it? Is that part I have on my ebay thread link in the first post the correct one? (so I'm sure I know what I'm looking...
Forum: Suspension Tech 05-11-2011, 10:53 AM
Replies: 14
Views: 6,436
Posted By Black04Ranger
Re: HUGE POTHOLE... broke something on suspension

Thanks man! Do I have the right part identified in my Ebay link?

Also, can I ghetto rig it somehow to keep the swaybar and link together right now til the replacement part shows up?


How do...
Forum: Suspension Tech 05-11-2011, 10:50 AM
Replies: 14
Views: 6,436
Posted By Black04Ranger
Re: HUGE POTHOLE... broke something on suspension

Pics added for ya.... i was in the process of saving them down... sry
Forum: Suspension Tech 05-11-2011, 10:41 AM
Replies: 14
Views: 6,436
Posted By Black04Ranger
HUGE POTHOLE... broke something on suspension

Well there guys... just as the title says.... I hit a HUGE pothole today (with the driver's side front tire) on the highway going about 60mph because some A-Hole swung into my lane almost right into...
Forum: Misc Items 04-25-2011, 05:49 AM
Replies: 67
Views: 5,505
Posted By Black04Ranger
Re: 4.0L SOHC and bed decals

Na.... the logos are super easy to install.... just clean the dirt off of the hood with normal car soap and water, then use a light mixture of dawn dish soap and water on a rag and wipe the area you...
Forum: 4.0 SOHC / 4.0 OHV Tech 02-11-2011, 06:56 AM
Replies: 103
Views: 14,850
Posted By Black04Ranger
Re: Random misfires when it snows

I thought I was through with this misshap, but I had my truck just do the "pothole" feeling twice on the way home the other day from work. It hasn't done this in about 1500+ miles.... it was barely...
Forum: Exterior Parts 01-14-2011, 08:33 AM
Replies: 9
Views: 1,327
Posted By Black04Ranger
Re: wheel arch/bumper trim?

I feel your pain man.... I'm missing the same piece, only its the drivers side not the passenger's that I'm missing.
Forum: 4.0 SOHC / 4.0 OHV Tech 01-12-2011, 09:36 AM
Replies: 103
Views: 14,850
Posted By Black04Ranger
Re: Random misfires when it snows

Well I have a K&N and it has not done it since that one day driving home. My K&N fits into the filter box SUPER snug and the gasket and latches close tightly. Maybe it was just having hiccups? ...
Forum: 4.0 SOHC / 4.0 OHV Tech 01-06-2011, 11:54 AM
Replies: 103
Views: 14,850
Posted By Black04Ranger
Re: Random misfires when it snows

Well my K&N is SUPER snug in there just like the stocker... I think that because of the massive amount of air that it lets through that the stocker does not, that somehow it was messing with the MAF....
Forum: General Tech 01-04-2011, 07:56 AM
Replies: 25
Views: 4,227
Posted By Black04Ranger
Re: Can someone PLEASE answer my question about ABS!

Is there a way to fix this bad sensor without having to buy an entire brand new part?
Forum: General Tech 01-02-2011, 05:44 AM
Replies: 25
Views: 4,227
Posted By Black04Ranger
Re: Can someone PLEASE answer my question about ABS!

So I got my truck scanned at autozone last night for you guys....

ABS CODE: #B1155
Reason: "Left front speed sensor, Circut Malfunction"

Any ideas on what this could be and how to fix it?
Forum: General Tech 12-31-2010, 06:52 AM
Replies: 25
Views: 4,227
Posted By Black04Ranger
Re: Can someone PLEASE answer my question about ABS!

Well all, I'll have the codes read this afternoon (hopefully around 5pm assuming they don't close early because of the holiday tonight).... and I'll let you know what they say.

As for the rear...
Forum: General Tech 12-30-2010, 05:22 PM
Replies: 25
Views: 4,227
Posted By Black04Ranger
Re: Can someone PLEASE answer my question about ABS!

So I just checked the following:
1. ABS 30amp fuse in engine bay - Fuse is good, not broken. :(

2. ABS sensor wire being plugged in still - ABS wires are still hooked into the clips located just...
Forum: General Tech 12-30-2010, 02:53 PM
Replies: 25
Views: 4,227
Posted By Black04Ranger
Re: Can someone PLEASE answer my question about ABS!

PS... thanks all for your suggestions.... I'll check all the following things when I get home:
1. ABS 30amp fuse in engine bay
2. ABS sensor wire being plugged in still
3. ABS sensor wire, checked...
Forum: General Ford Ranger Discussion 12-30-2010, 02:45 PM
Replies: 15,998
Views: 798,504
Posted By Black04Ranger
Re: What did you do to your ranger today thread

Almost slid into my GF's car because the ABS went out 2 nights ago and I had black ice all over the driveway this morning.
Forum: General Tech 12-30-2010, 02:37 PM
Replies: 25
Views: 4,227
Posted By Black04Ranger
Re: Can someone PLEASE answer my question about ABS!

I'll have to look under the truck when I get home to see if the ABS wire is OK.... not sure what it looks like exactly though.... anybody got a picture of what I'm looking for?



Is that ABS...
Forum: 4.0 SOHC / 4.0 OHV Tech 12-30-2010, 02:29 PM
Replies: 32
Views: 3,490
Posted By Black04Ranger
Re: Needs advice 4.0 only getting 11 mpg any suggestions?

Bump... I'm curious how your MPG have improved or not since your fix?
Showing results 1 to 25 of 127