Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Ford Ranger Forum - Forums for Ford Ranger enthusiasts! (http://www.fordrangerforum.com/)
-   4-Cylinder Tech (http://www.fordrangerforum.com/4-cylinder-tech/)
-   -   A/C Doesn't Run at idle (http://www.fordrangerforum.com/4-cylinder-tech/33962-doesnt-run-idle.html)

Mack91 05-21-2011 08:36 AM

A/C Doesn't Run at idle
 
For some reason, my 95 4CLY 4WD doesn't run its air conditioning while it's idling. Stoplights suck pretty bad currently. I have no idea why this would be.. The compressor cuts on, but cuts off right after. It runs cold when I'm driving..

Any ideas? Thanks!

zipsayain 05-21-2011 06:14 PM

Re: A/C Doesn't Run at idle
 
Mine does it to, if stop for too long.

FireRanger 05-21-2011 06:22 PM

Re: A/C Doesn't Run at idle
 
I bet something is wrong with your fan. When you're moving, air is moving through the grill. When you stop, without a working fan, no air through the grill equals no AC.

When you're stopped, if you step on the gas to bring the RPM up, does the problem remain?

Mack91 05-22-2011 07:11 AM

Re: A/C Doesn't Run at idle
 
Quote:

Originally Posted by FireRanger (Post 428561)
I bet something is wrong with your fan. When you're moving, air is moving through the grill. When you stop, without a working fan, no air through the grill equals no AC.

When you're stopped, if you step on the gas to bring the RPM up, does the problem remain?

Yeah, but I have an electric fan wired to the truck. It runs while I'm stopped anyway.

The RPM's while stopped haven't really made an impact that I can tell.

It's like the truck just cuts it off while it's idling... My Hayne's manual is no help to this of course.

FireRanger 05-22-2011 07:43 AM

Re: A/C Doesn't Run at idle
 
That makes me suspect the fan even more. Next time you stop and the AC quits, open the window or get out and look/listen. I bet the fan won't be moving. The reason I suspect this is because you're saying that bringing the RPM up while stopped doesn't change it.

Mack91 05-24-2011 06:05 PM

Re: A/C Doesn't Run at idle
 
Thanks I'll look into that. I really have no idea how it is wired.. PO work. haha

PureCountry95 06-05-2011 01:36 PM

Re: A/C Doesn't Run at idle
 
I have this same problem. It runs cold when driving, but when stopped at a light, not on the gas, the air gets hot. (I do not have an RPM Gauge)

Rg1Baja 06-05-2011 07:07 PM

Re: A/C Doesn't Run at idle
 
Check the a/c pressures?

bubonic0 07-31-2011 06:17 AM

Re: A/C Doesn't Run at idle
 
I'm having the same problem, and was told it is the cycling switch on the low pressure side...Replaced it and it seems worse than ever. Now the a/c clutch is kicking out sometimes even while driving at higher rpm than idling. It's an old 96 XLT 2.3 liter 4x4 with 197,000 miles.
Thanks for any help guys.

killj0y 08-02-2011 08:24 AM

Re: A/C Doesn't Run at idle
 
low suction/pressure in the system probably

dregiste1 08-02-2011 08:47 AM

Re: A/C Doesn't Run at idle
 
I'm having the same problem. Anytime I'm in idle the compressor shuts off, but as soon as I give it some gas the compressor kicks on. My father in law thinks it's a vacuum leak. Since it only does it in idle, and the idle is a little rough anyway, he thinks the cpu is telling the compressor to stay off because it's not running at a high enough rpm. Can a vacuum leak cause this issue? We've sprayed 2 1/2 cans of carb cleaner on the motor looking for a leak and can't find one.

dvrich 08-04-2011 02:51 PM

Re: A/C Doesn't Run at idle
 
Quote:

Originally Posted by FireRanger (Post 428951)
That makes me suspect the fan even more. Next time you stop and the AC quits, open the window or get out and look/listen. I bet the fan won't be moving. The reason I suspect this is because you're saying that bringing the RPM up while stopped doesn't change it.


Could be the compressor clutch sticking. Before I replaced one on my 89 a long time ago the only way I could get the clutch to engage was to race the engine briefly. Or maybe the electric fan is not pulling enough air through the coils.

Mack91 08-04-2011 05:48 PM

Re: A/C Doesn't Run at idle
 
I'm still not sure what the issue is. I'm thinking that the system needs to be pulled down and charged. That's what my mechanic said is the likely cause. I'll post if I fix it.

vishous 08-04-2011 06:52 PM

Re: A/C Doesn't Run at idle
 
sounds like low pressure, when u drive it builds higher pressure and when stopped u loose it. make sure system is full


All times are GMT -7. The time now is 11:17 AM.