Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Ford Ranger Forum - Forums for Ford Ranger enthusiasts! (http://www.fordrangerforum.com/)
-   Introduce Yourself (http://www.fordrangerforum.com/introduce-yourself/)
-   -   CatmanDave (http://www.fordrangerforum.com/introduce-yourself/28131-catmandave.html)

CatmanDave 03-04-2011 06:24 AM

CatmanDave
 
Hello, I'm known as Catman Dave and I own a 1986 Ranger XLT.

CatmanDave 03-04-2011 06:50 AM

Re: CatmanDave
 
I'm having a stalling problem. AFter I drive for 10 miles or so and the truck gets up to complete running tempeture. At that point if I give it full throttle in neuteral it seems to rev up normally but in gear it reachs 2000 rpm then it boggs down and tries to stall. It will set and idle all day. I've replaced the following to no avail TFI module,Spark plugs,Fuel Filter, Fuel Pump(electric on on frame) and the TPSmodule. I've even taken the EGR valve off and checked it and it is fine. This truck does have factory dual tanks and they were both cleaned and had all new pumps and sending units installed. The puzzling part is that when it's cold it runs like a champ.

----------

:confused:I'm having a stalling problem. AFter I drive for 10 miles or so and the truck gets up to complete running tempeture. At that point if I give it full throttle in neuteral it seems to rev up normally but in gear it reachs 2000 rpm then it boggs down and tries to stall. It will set and idle all day. I've replaced the following to no avail TFI module,Spark plugs,Fuel Filter, Fuel Pump(electric on on frame) and the TPSmodule. I've even taken the EGR valve off and checked it and it is fine. This truck does have factory dual tanks and they were both cleaned and had all new pumps and sending units installed. The puzzling part is that when it's cold it runs like a champ.

----------

:confused:I'm having a stalling problem. AFter I drive for 10 miles or so and the truck gets up to complete running tempeture. At that point if I give it full throttle in neuteral it seems to rev up normally but in gear it reachs 2000 rpm then it boggs down and tries to stall. It will set and idle all day. I've replaced the following to no avail TFI module,Spark plugs,Fuel Filter, Fuel Pump(electric on on frame) and the TPSmodule. I've even taken the EGR valve off and checked it and it is fine. This truck does have factory dual tanks and they were both cleaned and had all new pumps and sending units installed. The puzzling part is that when it's cold it runs like a champ.

Tsevg9 03-04-2011 06:51 AM

Re: CatmanDave
 
Welcome to FRF Catman Dave. Sorry, I'm not a technical person so I can't help ya. I know someone here will soon though.

TerrenceStuart 03-04-2011 09:14 AM

Re: CatmanDave
 
welcome to FRF, David!

FordDude1991 03-04-2011 09:37 AM

Re: CatmanDave
 
check your IAC

STL 03-04-2011 05:55 PM

Re: CatmanDave
 
Welcome to FRF

Please post tech questions in the correct section for a better response.

bugz1racing 03-05-2011 07:51 AM

Re: CatmanDave
 
Welcome

esrevnoc 03-06-2011 04:58 AM

Re: CatmanDave
 
Welcome to FRF.

Ranger Sport 03-06-2011 05:05 AM

Re: CatmanDave
 
Welcome to FRF!

Clinton 03-07-2011 10:31 PM

Re: CatmanDave
 
Welcome


All times are GMT -7. The time now is 01:42 PM.