Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Ford Ranger Forum - Forums for Ford Ranger enthusiasts! (http://www.fordrangerforum.com/)
-   Other Engine Tech (http://www.fordrangerforum.com/other-engine-tech/)
-   -   Totally stumped (http://www.fordrangerforum.com/other-engine-tech/137161-totally-stumped.html)

Arnie10 06-19-2016 04:00 AM

Totally stumped
 
Hello everyone, I am looking for some experienced Ranger owner help.
I have a Ford Ranger 4x4 XLT 2.5 turbo diesel, it has given me many years of faultless operation until now, when I start it from cold I have a misfire that requires me to rev it or it will stall but after a short time when warm it runs perfectly, but I have just found that if I rest my foot on the clutch pedal ( do not have to press it) the misfire dissapears and it runs perfect again, if I drive it from cold I cannot accelerate without it jerking ,jumping and kangarooing down the road until I lift off the throttle, again after a few miles it runs great, but if I rest my foot on the clutch again, just taking out the free play it runs perfect. I have cleaned the EGR valve replaced the glow plugs, fuel filter and air filter, used a diesel injector treatment, none of which make a difference. It is the link with the clutch pedal that has me confused so if any of you experts can help, please let me know. Looking forward to hearing from anyone, thanks for reading.

Big 4.0 power 06-19-2016 05:22 AM

Well, we don't have diesel rangers in the states, but I'm sure someone around here works on diesels so they can put their .2 cents in. To me sounds like a injector problem or a clogged fuel filter. Just my .2 cents

Arnie10 06-19-2016 11:03 AM

Re: Totally stumped
 
Thanks big 4.0 power, I have changed the filter no joy and used some injector cleaner in the fuel, still no joy, I was thinking along this line until I found that pressing the clutch pedal slightly cleared the problem and it returned when pedal was lifted.
My real question is what link has the clutch pedal got electrically as it must be some kind of electronic sensor fault, but which one.:damnmate:

bjurke 06-22-2016 12:13 PM

Re: Totally stumped
 
I would forget about the clutch. You should have your motor scanned for codes. Probably a over lean running condition. Usual candidates are fuel pump, oxygen sensor, and air leaks

rangeredge2014 06-29-2016 01:14 PM

Re: Totally stumped
 
I had a diesel that did the same thing ran horrible when cold but excellent when hot it was a failing injector

NoPower 06-29-2016 03:56 PM

Re: Totally stumped
 
I see alot of good things about Hot Shots Secret Striction Eliminator. www.hotshotsecret.com They have it for fuel and oil. Cleans everything. People love this stuff. they make it for gas or diesel.

rory.burns64 04-22-2017 12:08 AM

Re: Totally stumped
 
Hi Guys. How do I improve my consumption . A friend of mine has a 2,5turbo diesel Ranger 2009 and getting around average 550 km per 70 Litre Tank. Would like some pointers as to what to look at to improve the consultation. Thanks a mill gents.

Sent from my 2014817 using Tapatalk


All times are GMT -7. The time now is 02:08 PM.