Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

twow612 twow612 is offline

Learning to use the forums

Visitor Messages

Showing Visitor Messages 1 to 2 of 2
  1. twow612
    09-21-2016 09:12 PM
    twow612
  2. twow612
    09-21-2016 09:10 PM
    twow612
    I have a 2001 2.5 4 cylinder with a manual transmission. I have a no crank no start condition. It was intermittent and now it does not start at all. I did get it to start for the first time in over a month but it did not start again. No door chime, dome light weak usually. The first time it occurred I found broken wire on the cam sensor plug wire. Repaired it and it was fine for a month or so until it started running like crap,the ABS light started flashing at me and my aftermarket stereo turned off. I need some help. Please. I'm about to light it on fire.

About Me

  • Signature
    RocknRolland the steel
    2001 Ford Ranger with 2.5 and the only reason I like it is because it's a manual.

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 01-18-2017 10:42 AM
  • Join Date: 09-21-2016
  • Referrals: 0

Feedback

iTrader Profile Recent Ratings
Feedback:
Positive Feedback:
0
0%
Members who left positive:
Members who left negative:
0
0
Total positive feedback: 0
View Complete Feedbacks for twow612
  Past
Month
Past
6 Months
Past
12 Months
 Positive 0 0 0
 Neutral 0 0 0
 Negative 0 0 0