Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

socalraider socalraider is offline

Learning to use the forums

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. socalraider
    03-17-2013 03:32 PM
    socalraider
    I have a 2001 Ford Ranger 4x4 with a 4.0 v6 and auto transmission. Today when I needed to use the 4wd, I activated the electric switch on the dash and nothing happened. I have used the 4wd on other occasions and it never failed to respond. The transfer case has never made any noise such as whining, crunching, or anything else. The fuse checked out OK. Any feed back as to whether this might be the switch or the transfer case electric motor? Has anybody else had this experience? I don't have a problem fixing it but before I start I would like to hear from other owners.

About Me

  • About socalraider
    Interests
    Off roading, shooting, hunting, 1966 Modified Ford Mustang Coup
    Occupation
    Retired IBEW Electrician
  • Signature
    socalraider4498

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 03-17-2013 06:00 PM
  • Join Date: 03-17-2013
  • Referrals: 0

Feedback

iTrader Profile Recent Ratings
Feedback:
Positive Feedback:
0
0%
Members who left positive:
Members who left negative:
0
0
Total positive feedback: 0
View Complete Feedbacks for socalraider
  Past
Month
Past
6 Months
Past
12 Months
 Positive 0 0 0
 Neutral 0 0 0
 Negative 0 0 0