Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

RedZombie RedZombie is offline

Learning to use the forums

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. RedZombie
    02-07-2011 01:25 PM
    I'm fairly new to this forum and not sure how to start a new thread. I have a 2002 4.0 L 4WD with 115K miles and automatic transmission. I just noticed it shifting late from first to second and kind of jerky a few weeks ago. All other gears shift fine. Then last week the O/D light began flashing as it shifts into 2nd gear. The code is p0733 (incorrect gear ratio). I'm worried that this is going to require a complete overhaul because both places I checked (small time mechanic and Ford dealer) throw out numbers like $2200. I've read stories online that would suggest that this is a common problem and there may be an easier more specific fix (solenoid, band, valve body gasket). I'm definitely not a mechanic, but my gut tells me that this could be a much easier/cheaper fix than what they tell me. The transmission was maintained and fluid level and color is good. I would appreciate any advice.

About Me

  • Signature
    2002 4.0 XLT 4WD


Total Posts
Visitor Messages
General Information
  • Last Activity: 05-07-2014 12:23 PM
  • Join Date: 07-26-2010
  • Referrals: 0


iTrader Profile Recent Ratings
Positive Feedback:
Members who left positive:
Members who left negative:
Total positive feedback: 0
View Complete Feedbacks for RedZombie
6 Months
12 Months
 Positive 0 0 0
 Neutral 0 0 0
 Negative 0 0 0