Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

realfunco realfunco is offline

Learning to use the forums

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. realfunco
    04-01-2014 05:56 PM
    realfunco
    I have a mazda B3000 or a Japanese badged Ford Ranger. It is a 3.0 L, 4x4, Manual Trans, 174,000 miles. It runs like poo on bottom end. I am down to the timing chan and it is so worn out. I have the new one on and it has a good firm fit. I ripped the oil pan gasket where the chain cover meets the oil pan.
    Do I need to pull the engine and replace the oil pan gasket? It appears to be a one piece oil pan gasket.

About Me

  • About realfunco
    Biography
    I bought my first car at 14 for $50 bucks
    Interests
    USED FORDS
    Occupation
    SALES
  • Signature
    i have a 96 Mazda B3000, 4x4, MT, 3.0 Vulcan. I put a used computer, all new sensors, including a speed sensor on the T case, 120 lbs compression on most cylinders. It went right up to 90 lbs and still no power. I am down to the tining chain,. It was soo bad. The new chain is firm.

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 04-03-2014 06:16 AM
  • Join Date: 04-01-2014
  • Referrals: 0

Feedback

iTrader Profile Recent Ratings
Feedback:
Positive Feedback:
0
0%
Members who left positive:
Members who left negative:
0
0
Total positive feedback: 0
View Complete Feedbacks for realfunco
  Past
Month
Past
6 Months
Past
12 Months
 Positive 0 0 0
 Neutral 0 0 0
 Negative 0 0 0