Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

pipefitt5 pipefitt5 is offline

Danger Ranger

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. pipefitt5
    02-23-2014 05:57 AM
    Its a 2006 4.0 sohc 4x4 .Ok here is my problem, i removed my engine after a timing guide failure like every other ranger. I replaced all chains, guides, sprockets,oil pump,valve seals,head gaskets. I timed it with the htc timing tool.Then i put it back together installed the engine back in the truck, try to fire it up, nothing was not receiving fuel. Because it has been sitting for 8months or so. Dropped the tank, replaced the fuel pump, cleaned the tank, added new fuel. But i did not replace the fuel filter, and the fuel in the lines is old too. So i try starting it and it trys to start but doesn't. It chugs like its trying to start. So i learn as i go by haynes ranger manual and ford forum along with friends advise. I have not tried fuel pressure test, or testing spark. Know when i timed it, both cams were put back in same order as took out, are not 180 degrees off. Spark plug wires are in correct order, all wiring is connected.

About Me

  • About pipefitt5
    working on cars
  • Signature
    Nicholas Seidelman


Total Posts
Visitor Messages
General Information
  • Last Activity: 03-31-2015 05:43 PM
  • Join Date: 12-25-2013
  • Referrals: 0


iTrader Profile Recent Ratings
Positive Feedback:
Members who left positive:
Members who left negative:
Total positive feedback: 0
View Complete Feedbacks for pipefitt5
6 Months
12 Months
 Positive 0 0 0
 Neutral 0 0 0
 Negative 0 0 0