Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Conversation Between Pbav8tor and 02RangerFX4
Showing Visitor Messages 1 to 10 of 13
  1. Pbav8tor
    12-03-2011 09:39 PM
    Not a problem. Good luck with your mods.
  2. 02RangerFX4
    12-03-2011 09:37 PM
    ok, thanks for everything!
  3. Pbav8tor
    12-03-2011 09:35 PM
    I colored the needles after putting in the overlays so I didn't see them white against the blue.
  4. 02RangerFX4
    12-03-2011 08:45 PM
    I mean i knew they looked white (sorry i should have made myself more clear)

    I meant how well could you see where your needles were before you colored them in?
  5. Pbav8tor
    12-03-2011 08:16 PM
    It wasn't that hard. I tapped the power from the dash lights. The needles looked white.
  6. 02RangerFX4
    12-03-2011 08:00 PM
    Was that pretty easy? Just disconnect where the old speedo lights were connected or just wire it in? And yeah, i didn't like the idea of a separate power supply for my instrument cluster. How did it look before you colored in your needles?
  7. Pbav8tor
    12-03-2011 07:43 PM
    The overlays have thier on power supply and light up blue. I tapped into the dash lights for power so they turn on when I turn on the lights, only makes sense.
  8. 02RangerFX4
    12-03-2011 02:35 PM
    Cool, did you change the bulbs to make it look blue?

    Or did they come like that?
  9. Pbav8tor
    12-03-2011 12:33 AM
    As far as I can tell they are very close to the ones I have. Also, being overlays you don't have to remove the needles. And my needles where clear which shows as white, I colored them red with a sharpie pen.
  10. 02RangerFX4
    12-02-2011 11:35 PM
    Ok, thanks!

    Are those on that link the ones you have?