Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Mike In Bama Mike In Bama is offline

Electronics Tech

Visitor Messages

Showing Visitor Messages 1 to 6 of 6
  1. Adpet1190
    05-11-2016 08:57 PM
    Adpet1190
    Thanks for info. Is the mods difficult? I haven't pulled my mirrors off yet to see what's it's all about. Thanks again!
  2. Futurefd
    12-06-2014 01:03 PM
    Futurefd
    1st off... THank you! your cb radio write up is the best. Anytime a member asks about cb I point them to your write up... good stuff..

    I had my cb antenna (K40 with magnetic mount) on my roof centered. Followed your directions and I could reach out many miles. good stuff.

    However I recently purchased a house and a 3 bay garage. I forgot to disconnect the antenna and I broke the darn thing, they gave me a new one under warranty (go k40)

    So now I can ether mount it back on the roof with the magnetic mount, OR I was thinking of mounting it to my hood using the "over the edge" feature. That way I would see it pulling into the garage and wont rip it apart.

    Though I am worried that my range may be affected even after tuning it in.

    SO what are your thoughts on mounting it to the hood?

    Thanks!





    Empty your inbox
  3. dtown33d
    09-12-2014 11:56 AM
    dtown33d
    mike i have a question
    I have a 2002 ford ranger 2.3l that loses power when accerating in every gear, it feels like a miss or kinda feels like fuel just cuts out at certain rpms and sometimes i will be flooring it and it has no power

    I have replaced:
    spark plugs
    spark plug wires
    coil pack
    fuel filter
    camshaft position sensor
    "clutch is good"
    "tranny is good"
  4. Sw3rvin
    07-13-2014 09:02 PM
    Sw3rvin
    Wondering about your AC vent fix. My drivers side vent doesn't blow as cold as the center ones...not sure if your fix would help. Let me know thanks!
  5. Alex44
    04-29-2014 05:58 PM
    Alex44
    Hi, I would be interested to have a look at your procedure for cleaning the MAF and the others sensors! My email is alexandre.pare@icloud.com

    Thanks a lot
  6. paholskila
    04-29-2014 10:15 AM
    paholskila
    I'm paholskila@comcast.net. Will welcome your how-to info for cleaning MAS etc. on 2005 Ranger/2.3 engine. As I posted on the forum, when I removed the sensor I really couldn't see the innards very well at all, so just sprayed CRC into the small opening and hoped it would do the job. Didn't want to get all crazy and try to pry open what looks like an intentionally sealed unit.

About Me

  • About Mike In Bama
    Biography
    Electronics Degree. Air Force Vet. - Wideband Comm (aka Radio Relay).
    Interests
    High-End Home Audio, Hobby Machinist, Artificer, Active In Animal Affairs
    Occupation
    Electronic Repairman
  • Signature
    2005 2.3L XL 5SOD 3.73 K&N
    KYB Shocks Husky Toolbox
    Alpine / Rockford Fosgate Sound

    "Ask me about my AC Vent fix!"

Statistics

Total Posts
Albums
Visitor Messages
General Information
  • Last Activity: 02-19-2017 05:49 PM
  • Join Date: 03-12-2013
  • Referrals: 0

Friends

Showing Friends 1 to 1 of 1

Feedback

iTrader Profile Recent Ratings
Feedback:
Positive Feedback:
0
0%
Members who left positive:
Members who left negative:
0
0
Total positive feedback: 0
View Complete Feedbacks for Mike In Bama
  Past
Month
Past
6 Months
Past
12 Months
 Positive 0 0 0
 Neutral 0 0 0
 Negative 0 0 0