Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

jpepe3691 jpepe3691 is offline

Learning to use the forums

Visitor Messages

Showing Visitor Messages 1 to 2 of 2
  1. jpepe3691
    07-18-2010 11:32 PM
    Hi all- I inherited an dark grey Base Model 88 Ranger, 2.3 FI, 2wd from my father, currently with 82,000 on it. Had it for about 10 years, and after a cheapo paint job, timing belt, water pump, R134 conversion- the ususal stuff- she runs great. I've visited this site in the past for ideas on mods, and answers to some of the pesky little "gremlins" that pop up from time to time. GREAT site!
  2. jpepe3691
    07-17-2010 11:21 AM
    Hello all. I inherited a dark grey 88 Ranger 2.3 FI, RWD BASE model with Auto trans about 10 years ago. It even has front Grille Guard! Go figure!
    Now has 82,000 on her. It was really neglected MOST of its life, so when I first got it I gave it new cheapo Maaco paint job, radiator, timing belt, water pump, catalytic- the usual stuff. Runs great now, except for the occasional "topping off" of R134a in my converted A/C!
    (I learned the hard way NOT to "top off" with refills that HAVE OIL since there's no more ROOM for more refrigerant)
    This is a great site, and I've gotten a lot of great info here!
    Between this site, and a little more TLC, the Ranger will be "free to roam" for at least another 80,000!



Total Posts
Visitor Messages
General Information
  • Last Activity: 04-03-2013 04:34 PM
  • Join Date: 03-07-2010
  • Referrals: 0


iTrader Profile Recent Ratings
Positive Feedback:
Members who left positive:
Members who left negative:
Total positive feedback: 0
View Complete Feedbacks for jpepe3691
6 Months
12 Months
 Positive 0 0 0
 Neutral 0 0 0
 Negative 0 0 0