Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

freddyzero freddyzero is offline

Learning to use the forums

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. freddyzero
    06-21-2014 05:32 AM
    Ok here is the situation. I have a 2007 2.3 manual transmission. I had head sent to the machine shop for a valve job. Mechanics got it back and put it together, but it came back with ticking noise. is constant like lifters maybe and valve clattering when I shift gears and hit the gas pedal, when I accelerate to get more speed. Took it back to them and told me that it might be because it is a new valve job and it would take about 500 miles to determined is something serious. I gave them the benefit of the doubt and drove off. Well it seems to be getting no better, and in fact it dies sometimes when on a red light. Man, I am disappointed and frustrated. My question is if it was a bad valve job from the machine shop or the mechanics? Any help would be very much appreciated. Oh yes, and it consumes 1qt. of oil every week!!

About Me

  • Signature
    '07 Ranger 2.3l 4cyl
    5 speed manual transmission
    sigle cab


Total Posts
Visitor Messages
General Information
  • Last Activity: 06-30-2014 05:18 AM
  • Join Date: 11-26-2013
  • Referrals: 0


iTrader Profile Recent Ratings
Positive Feedback:
Members who left positive:
Members who left negative:
Total positive feedback: 0
View Complete Feedbacks for freddyzero
6 Months
12 Months
 Positive 0 0 0
 Neutral 0 0 0
 Negative 0 0 0