Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

FRA33 FRA33 is offline

Learning to use the forums

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. FRA33
    06-05-2014 10:26 AM
    FRA33
    I have been working on ford ranger for a couple of months, Most of the ar easy to fix. it's just my hobie. I resent replace Fuel Pump. I remove the Tank ispected all inside replace fuel pump and clean the gas tank replace all ruber hoses in tank and outside. NOW A HAVE A PROBLEM, Truck dies ever 5 to 10 min drive, I had Inspected all vacum lines I replace all air filter and any vacum line that look suspisious. I don't believe is the Fuel Pump. gas presure it's at 45 Any one out there that had this problem. I also replace all spark plug wire and air filter oil change wih filter. It’s anyone out there that will share their Knowledge, I will share all my experience on this lovely trucks….
    PLEASE SEND ME ANY INFORMATION THAT YOU CAN SHARE ON THIS PROBLEM.
    My Name CISCO… E-mail FRA33@live.com

About Me

  • About FRA33
    Occupation
    Budget Analyst

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 07-16-2014 04:19 PM
  • Join Date: 06-05-2014
  • Referrals: 0

Feedback

iTrader Profile Recent Ratings
Feedback:
Positive Feedback:
0
0%
Members who left positive:
Members who left negative:
0
0
Total positive feedback: 0
View Complete Feedbacks for FRA33
  Past
Month
Past
6 Months
Past
12 Months
 Positive 0 0 0
 Neutral 0 0 0
 Negative 0 0 0