Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

FireRanger FireRanger is offline

Blinded by the light

Visitor Messages

Showing Visitor Messages 21 to 29 of 29
  1. djfllmn
    01-03-2012 07:15 PM
    djfllmn
    thanks! question for you though...i tried to wire up my high beams and they didnt work...there are 2 wires...red and black going to the shutter and i tried hooking them up to the red black on the 9007 plug on the hid harness and they didnt work...what wires did you tap into for the high beams...since were both 03s wire colors should be the same
  2. djfllmn
    01-03-2012 06:49 PM
    djfllmn
    did you see i finally got projectors and HIDs?
  3. 01B3000
    12-23-2011 11:40 PM
    01B3000
    eh, figured i ask. ill just have to take it apart in the spring one weekend.
  4. 01B3000
    12-22-2011 09:30 PM
    01B3000
    You seem to be a good expert on cooling systems.
    Anyways, i broke 1 bolt on my water pump last year insstalling it (one of the baby ones)
    Now i have a small coolant leak from my timing cover, could it be from that bolt, im pretty sure the water pump bolts dont hold on the timing cover.

    Oh great matt please bestow me with your knowledge. lol
  5. michele27
    11-22-2011 08:02 AM
    michele27
    Hi! I was told to contact you and see you can help me with my starting issue. I have a 2004 Ranger, XLT with the 4ltr. It ran fine up until about 3 weeks ago. I tried to start it and it turns over, it just wont start. I rented a fuel pressure gauage and the pressure was ok, BUT the truck also started the day we tested it, that day we replaced the mass air flow sensor and it ran all day and the next day when I went to start it, it wouldnt start again. I checked the relays and they seem fine. It been sitting in the driveway for 3 days now, tried jumping it, nothing. Tried taking the air intake off to see if it was a air issue, still wont start. At one poin I as able to press the fuel shutoff switch and it would start again but that does not do anyting anymore. I was wondering if the switch could be faulty, or has gone out?? Any suggestions? Any advice is appreciated. Thanks!
  6. FireRanger
    10-28-2011 07:09 PM
    FireRanger
    It's my old '84 that I plowed sideways into a tree
  7. HIGH TECH REDNECK
    10-28-2011 05:14 PM
    HIGH TECH REDNECK
    ive always wondered, whats in your avatar pic?
  8. PKidd
    09-06-2011 09:43 PM
    PKidd
    Where would the negative on the switch connect to if I dont wanna use a fuse in my fuse box?
  9. Monster Mule Deer
    04-30-2011 09:01 PM
    Monster Mule Deer
    Hey man. You're smart, and I have a dilemma. I posted a thread for help: http://www.fordrangerforum.com/audio...ling-help.html

About Me

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 05-15-2013 06:55 AM
  • Join Date: 09-18-2009
  • Referrals: 2

Friends

Showing Friends 1 to 10 of 23

Contact Info

Instant Messaging
Send an Instant Message to FireRanger Using...
This Page
http://www.fordrangerforum.com/members/fireranger.html

Feedback

iTrader Profile Recent Ratings
Feedback:
Positive Feedback:
1
100.0%
Members who left positive:
Members who left negative:
1
0
Total positive feedback: 1
View Complete Feedbacks for FireRanger
  Past
Month
Past
6 Months
Past
12 Months
 Positive 0 0 0
 Neutral 0 0 0
 Negative 0 0 0