Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Dave99 Dave99 is offline

Learning to use the forums

Visitor Messages

Showing Visitor Messages 1 to 3 of 3
  1. Spirit of America
    11-26-2012 04:41 PM
    Spirit of America
    srry i didnt respond till now dave, been away, go to rock auto and type arm100 or ARM100 into the part number box
  2. Dave99
    03-14-2012 09:53 AM
    Dave99
    Ok, so I've got a 02 4x4 4.0 supercab FX4 with 128,000 miles on it. I have a problem. Mostly in reverse, but sometimes going forward particulaly when turning at low speed, just when you put your foot on the gas There is a slight vibration that feels like it's coming from the front end I had all the breaks checked/done and I've had all the bushing checked all is in good shape. However yesterday I noticed it while backing out of the garage and it sounded like a clunk and clicking noises coming from the rear end somewhere.

    I have heard something about the wrong oil in the rear diff being the problem but that seems a little wierd, has anyone got any advise/expierence with this ? any help with would be great, Thanks.
  3. prerunger
    01-25-2012 12:22 PM
    prerunger
    I got my fiberglass done

About Me

  • About Dave99
    Interests
    anything with a motor, guns, golf and girls.
  • Signature
    2002 FORD RANGER 4.0 AUTO FX4 OFF ROAD
    WEDGEWOOD MET 127K

Statistics

Total Posts
Albums
Visitor Messages
General Information
  • Last Activity: 09-17-2012 03:16 PM
  • Join Date: 01-22-2012
  • Referrals: 0

Feedback

iTrader Profile Recent Ratings
Feedback:
Positive Feedback:
0
0%
Members who left positive:
Members who left negative:
0
0
Total positive feedback: 0
View Complete Feedbacks for Dave99
  Past
Month
Past
6 Months
Past
12 Months
 Positive 0 0 0
 Neutral 0 0 0
 Negative 0 0 0