Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

ChadQueirolo ChadQueirolo is offline

Learning to use the forums

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. Btober
    07-28-2010 10:12 PM
    Hey So I not very car or computer literate, however my Ford 2005 Ranger is having the same exact problem that yours is having. The first time it died was in traffic after I had just put in $50 of unleaded gasoline. I've been told that it could possibly be the that something got caught in my fuel injectors? ? ? Basically cause I did run out of gas about a month ago and when I filled it up again possibly some of the sediment from the bottom of the fuel tank was washed into the line. Still that doesn't answer all the problems like "why would it start a few hours later?" IDK but it died agian leaving work on monday and I finally got it towed to Ford of Kirkland. If they figure out what it is I'll post it. But this sucks, Took me an extra 4hrs the past two days to get to work. Blah

About Me

  • Signature
    Chad Queirolo, Seattle. 2005 Ford Ranger 2dr SuperCab 4WD(4.0L 6cyl 5M)


Total Posts
Visitor Messages
General Information
  • Last Activity: 12-06-2010 03:28 PM
  • Join Date: 06-11-2010
  • Referrals: 0


iTrader Profile Recent Ratings
Positive Feedback:
Members who left positive:
Members who left negative:
Total positive feedback: 0
View Complete Feedbacks for ChadQueirolo
6 Months
12 Months
 Positive 0 0 0
 Neutral 0 0 0
 Negative 0 0 0