Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Bowz Bowz is offline

Ford Motor Company

Visitor Messages

Showing Visitor Messages 1 to 10 of 12
  1. ColinB2001
    02-06-2012 05:47 AM
    Yeah, i had installed a whole new stereo system. Subs, Amp, new speakers and head unit. And there was one wire behind the stereo touching metal and caused a short.
  2. rangerwheelinmike
    09-04-2011 06:19 AM
    ill get a vid of mine to
  3. Bowz
    09-04-2011 12:20 AM
    lol you and the Georgia/Southern Region both want that video.. Next time i got my camera in the truck I'll try and find a back road for you all and give her a run. If I had her built fully solid I'd give you all a quarter mile time.
  4. rangerwheelinmike
    09-03-2011 09:13 AM
    nope theres no vac leaks have checked many times. is yours a pig of the line? mine dont really get goin till bought 4000 rpm you should take a vid of your speedo from a stop and just floor it
  5. Bowz
    09-03-2011 12:22 AM
    sounds like a vacuum leak
  6. rangerwheelinmike
    09-01-2011 10:28 PM
    idk? mine runs good but when its cold and you put in gear and hold brake it revs up and down and wants to stall till it worms up
  7. Bowz
    09-01-2011 12:01 PM
    mine still runs a little rich but that right now is because of the O2 sensor going bad or reading bad.. everything on my truck from the gas tank up is literally the Mountaineer.. I took the pump and fuel lines from the mountaineer and moved it over.. I took it to a return system. The only thing so far that is giving me issues is the fact that the float in my system likes to sink from time to time and it gives me a bad reading on how much gas is in the truck. Everything in my engine to gas is all mountaineer. I even have a pressure gauge on the rail that i use every now and then to see how much the fuel pump still pumps to the rail. Is this all because i get more MPG then you?
  8. rangerwheelinmike
    09-01-2011 11:27 AM
    what did you do for the fuel system? on mine i put injectors and rail off a newer explorer 5.0 that dident use a return line and used my stock pump and lines but used the computer and harnes out of the 97 and it runs a lil ritch
  9. Bowz
    09-01-2011 11:01 AM
    yeah most of it was done by me. the only time i had help was to get it in and out of the truck and mountaineer, so i could help guide it and someone pull on the cherry picker.
  10. rangerwheelinmike
    08-31-2011 11:11 PM
    did you do the 5.0 swap your self?

About Me

  • About Bowz
    Currently trying to become a mechanic
    Wolves fast cars and offroading with a ranger
    process of mechanic
  • Signature
    98 Ranger 5.Go AWD

    Mods: Flowmaster 40 series exhaust turn downs. and K&N filter.


Total Posts
Visitor Messages
General Information
  • Last Activity: 07-03-2012 12:13 PM
  • Join Date: 10-03-2010
  • Referrals: 0


Showing Friends 1 to 5 of 5

Contact Info

Instant Messaging
Send an Instant Message to Bowz Using...
This Page


iTrader Profile Recent Ratings
Positive Feedback:
Members who left positive:
Members who left negative:
Total positive feedback: 0
View Complete Feedbacks for Bowz
6 Months
12 Months
 Positive 0 0 0
 Neutral 0 0 0
 Negative 0 0 0