Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Bosswagg Bosswagg is offline

Learning to use the forums

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. Bosswagg
    05-26-2011 08:31 PM
    I'm having issues with a 2000 Ford Ranger. It has the 2.5 ,4 cylynder and about 100,000 miles. Recently has been sputring then dying but starts right up after it dies. Replaced the Battery and fuel filter. Daughter took to a shop yesterday because an engine light (yellow) was coming on and it was the crank sensor or something. The guy at the shop reset the light and said the sensor has something to do with a valve being open when it shouldn't be affecting compresion. He was able to get the truck to finally die on him twice bbut didn't know what the cause was. He said he felt that replacing the sensor wasn't the issue as it probably came on a result of another issue causing the truck to die. He said he felt if it was the sensor being bad the truck wouldn't restart easily. My only option at this point is to send it to the FORD house which sounds expensive. Didn't know if you a member might be able to explain what the cause may be. Any help would be appreciated

About Me

  • Signature
    Bosswagg2000 Ford Ranger 2 wheel drive, 4 cylinder


Total Posts
Visitor Messages
General Information
  • Last Activity: 06-05-2011 11:40 AM
  • Join Date: 05-26-2011
  • Referrals: 0


iTrader Profile Recent Ratings
Positive Feedback:
Members who left positive:
Members who left negative:
Total positive feedback: 0
View Complete Feedbacks for Bosswagg
6 Months
12 Months
 Positive 0 0 0
 Neutral 0 0 0
 Negative 0 0 0