Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

allenhuang allenhuang is offline

Learning to use the forums

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. allenhuang
    11-26-2014 07:00 PM
    My 2006 ranger, mileage only 50,XXX. It runs well most of time, it has one problem, while driving, it suddenly lost power, wont start again. When try to start it again, can hear the engine cranking, seems try to start, but wont start to run. However, after a few hours, or next day, it can run well again. This problem happen one or twice in a year. However, this time, yesterday, it happened again, While I was driving, only a minute away from home, the engine stop. I try to start it today, and cannot make it run again.

    I check the battery, still very good.
    The starter is good, I can see the engine turn while I turn the key to start.

    I search web, don't see many cases with similar problem. Three years ago, I have taken it to two mechanics, both them cannot figure it out.

    Do you have some ideas which parts I should check? I am thinking it is wiring or some kind or switch/valve problem?


Total Posts
Visitor Messages
General Information
  • Last Activity: 11-27-2014 11:27 AM
  • Join Date: 11-26-2014
  • Referrals: 0


iTrader Profile Recent Ratings
Positive Feedback:
Members who left positive:
Members who left negative:
Total positive feedback: 0
View Complete Feedbacks for allenhuang
6 Months
12 Months
 Positive 0 0 0
 Neutral 0 0 0
 Negative 0 0 0