Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Albinator Albinator is offline

Learning to use the forums

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. Albinator
    07-07-2014 05:26 PM
    Hi Rangers!

    This is my first post due to a question I have, so I hope I'm doing this correctly...if not please lend me a hand.

    I have a 1991 Ford Ranger 2.9 L XLT with 157,500+ miles on it. I have put some work into it this summer and have come across an issue, which I hope those of you on this site can help with.

    This first video is about a "ticking noise" when the truck is in 4x4. Bad U-Joint?:

    This second video is after I turn off 4x4 to hit the road home. I apologize for the wind noise. You can definitely hear the noise inside the cab. I was told this age of car with 4x4 has some vacuum system and it's taking it a while to release? I have no idea:

    Any help would be great! I'm just debating whether it's worth to keep putting work into this Ranger or upgrade. I hear these trucks can take on some high milage.

    Thanks in advance!

About Me

  • Signature
    1991 Ford Ranger XLT 2.9 L 4x4


Total Posts
Visitor Messages
General Information
  • Last Activity: 07-19-2014 04:11 PM
  • Join Date: 07-07-2014
  • Referrals: 0


iTrader Profile Recent Ratings
Positive Feedback:
Members who left positive:
Members who left negative:
Total positive feedback: 0
View Complete Feedbacks for Albinator
6 Months
12 Months
 Positive 0 0 0
 Neutral 0 0 0
 Negative 0 0 0