Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

1964@15 1964@15 is offline

Learning to use the forums

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. 1964@15
    07-08-2013 07:33 PM
    Good evening. I have a 97 xlt extended cab 4x4 170k. Having an issue with the 4wheel drive. Last winter I had some problems with auto lock hubs after letting someone use the truck. Have a hunch it was driven extensively in 4wd on dry pavement. Anyway-- changed out the auto hubs with manual and all seemed well. Have not used the 4wd for few months but noticed a clicking sound when driving-- almost sounded like a rock under a wheel cover. Pulled the left hub apart and could tell the outside bearing was not overly greased. Repacked the bearing and put everything back together. Turned the wheel by hand and all seemed to be rolling smooth. Locked the hub and turned but it seems to be binding up. Right side turns smooth until I lock it up. This is with the transfer case disengaged but engaging it makes no difference. I noticed this binding problem "before" I repacked the bearing. Any ideas??? thanks for any help

About Me

  • About 1964@15
    i'm old and cranky kinda like my trucks
    motorcycles,old trucks,travel


Total Posts
Visitor Messages
General Information
  • Last Activity: 07-09-2013 09:48 AM
  • Join Date: 07-08-2013
  • Referrals: 0


iTrader Profile Recent Ratings
Positive Feedback:
Members who left positive:
Members who left negative:
Total positive feedback: 0
View Complete Feedbacks for 1964@15
6 Months
12 Months
 Positive 0 0 0
 Neutral 0 0 0
 Negative 0 0 0