Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Thread Tools Search this Thread

Old 03-12-2010, 08:05 PM
black95ranger black95ranger is offline
Learning to use the forums
Join Date: Mar 2010
Posts: 1
Default Newbie from Northern Virginia

Hi there. I have a one-owner '95 Ranger extended cab XLT, 4.0 liter, automatic, 180,000 miles, superbly kept, always clean. interior looks like new; oil/filter changed religiously every 5,000 miles. Maintenance (belts, plugs, wires, fluids, filters, etc.) always done before it's needed.

Recently, has developed a rough idle condition but ONLY after the truck is driven for an extended time (say, an hour on the Interstate) and then ONLY when starting it again (say, after a short stop for lunch). Engine idles like it's got a plug wire loose, or a loose vacuum line. Oddly, though, the idle smooths out after putting the truck in gear and driving off. Doesn't throw any codes (I have my own code scanner); fuel mileage is and has been consistently around 23.5 on long trips and around 18-20 in stop-and-go traffic using 10% alcohol in the gas.

Any thoughts?
Reply With Quote
Old 03-12-2010, 08:18 PM
TerrenceStuart TerrenceStuart is offline
Join Date: Nov 2009
Posts: 14,843
Default Re: Newbie from Northern Virginia

welcome to FRF, Richard!
2007 EXPLORER 4.0 4X4
Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Is there anybody out there? (Northern Nevada) rockisnotded Western Region 3 02-16-2010 09:12 PM
Hello form Northern Michigan EERNGER Introduce Yourself 12 02-11-2010 06:23 PM
Snow in Virginia Beach olfordtruck Vehicle Snapshots 9 02-03-2010 01:35 PM
Helllo from Northern Calf!! (1st Post) Dang Introduce Yourself 13 12-05-2009 10:37 AM
new from virginia STXCougar Introduce Yourself 6 05-25-2009 10:01 PM