Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 05-08-2009, 02:41 PM
tonyarf tonyarf is offline
Learning to use the forums
 
Join Date: May 2009
Posts: 3
Cool new yorker long time ranger owner

love my 90 extended cab 2.9 truck. i'm 6'4'' and 400 lbs. love the room in my ranger.

need help put new motor in truck. no matter what i do i have a skip under a load. runs great in parked but go to drive it i have a skip. not vacume-new plugs- new wires- new cap. seems to be no.4 cly. it has 140 lbs. on cly. going crazy. HELP
Reply With Quote
  #2  
Old 05-08-2009, 02:43 PM
tonyarf tonyarf is offline
Learning to use the forums
 
Join Date: May 2009
Posts: 3
Default

help my truck
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
I have a 20 foot long deck boat, should I have any problems towing it stanleyshepperson General Ford Ranger Discussion 7 04-05-2010 08:03 AM
93 ranger build... lots to do over a long time haha beaujt Project Logs 7 11-26-2009 11:02 PM
Maintenance time... 20Thunderbolt02 General Ford Ranger Discussion 3 07-14-2009 05:51 PM
Long time ranger owner. Airtruksrus Introduce Yourself 6 05-03-2009 12:40 PM
what would cause my 88 ranger pickup to take long to warm up before running right.? smiles General Ford Ranger Discussion 2 11-26-2008 11:58 PM