Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 06-30-2011, 05:15 AM
tootsie1 tootsie1 is offline
Learning to use the forums
 
Join Date: Jun 2011
Posts: 4
Red face Wipers gone south

Any history about the ranger's wipers/washer just quiting? no blown fuses/connections clean/no obvious wires unplugged. Manual list a ton of relays and dianostic run downs, sigh. Comments
Thanks, Tootsie1:
__________________
06 Ranger/3.0/STD cab/Auto/2WD
Tootsie1
Reply With Quote
  #2  
Old 06-30-2011, 06:19 AM
Christianguy Christianguy is offline
TRUCK SOLD!
 
Join Date: Feb 2011
Posts: 2,025
Default Re: Wipers gone south

Sorry I can't help you !

Welcome to this forum,though!
__________________
1999 Ford Ranger XL
Vulcan V6, K&N 33-2106 Filter, 3:73 Gears,
FRONT 3'' Susp Lift/REAR 3'' susp.+ 3" blocks,06 Mirrors
31"/10.5"-15" BFG on AR-172 Polished Rims,Smitybilt Console
95 Mustang Saleen Seats,Alternating Blinker MOD
Pioneer CD/iPod/GPS,6.5 Polk Audio/6.5 Sub-Woofers,
Stainless Bed Extender,Throttle and Dome Light MOD,
12" Tool Box,Billet Grille,NightShade Tint,Projector Headlamps
6000K H.I.D. so i can see at night! LOL


JESUS is LORD!
Reply With Quote
  #3  
Old 06-30-2011, 06:30 AM
StealthRanger StealthRanger is offline
RIP Jason Finn
 
Join Date: May 2011
Posts: 2,605
Default Re: Wipers gone south

Welcome to FRF!

Sorry, I can't help you with this problem either, but if you will post this question in the "Exterior Tech" part of this forum, you will be much more likely to get an answer. hopefully someone can help you out with this!
__________________
__________________

99 Ext Cab Stepside 3.0 XLT 4x4 & L/S 4:10 Gears.
Mods, Click ===> StealthRanger's Build Thread!

Quote:
Originally Posted by Blacked Out FX4 View Post
Are two naked girls in your bed better than one? Question answered
Quote:
Originally Posted by naturecakezzz View Post
Black out ftw!!
Reply With Quote
  #4  
Old 06-30-2011, 09:19 AM
Clinton Clinton is offline
Banned
 
Join Date: Mar 2010
Posts: 14,049
Default Re: Wipers gone south

Welcome. Check your owners manual for fuse/relay locations. The relay box under the hood is clearly marked as well so you can start from there
Reply With Quote
  #5  
Old 06-30-2011, 12:39 PM
TerrenceStuart TerrenceStuart is offline
Old man driver.
 
Join Date: Nov 2009
Posts: 14,895
Default Re: Wipers gone south

welcome to FRF, T.!
__________________
some kind of vehicle.
Reply With Quote
  #6  
Old 06-30-2011, 01:52 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default Re: Wipers gone south

Welcome to FRF
__________________
2005 Edge

Reply With Quote
  #7  
Old 06-30-2011, 01:53 PM
richarddhoward richarddhoward is offline
Road Trippin' King!
 
Join Date: Nov 2009
Posts: 5,010
Send a message via MSN to richarddhoward
Default Re: Wipers gone south

Welcome to FRF. As for Rangers killing wiper motors...I'd say is fairly uncommon. Check all the fuses and relays, as well as the motors themselves. I've had them give out on a car before, and it SUCKED! I'd say these would be just fine to hit up a junkyard for.
__________________
97 Ranger - 4.0 V6 auto, 4wd, 31x10.5x15s Wild Country XTX Sport All Terrains, Warn locking hubs, Pioneer deck with iPod attachment, Snugtop Topper, K&N filter, scan gauge II, Hella 500 Lights, More parts coming, waiting for the paycheck to get bigger!

Truck built in loving memory of Norm Howard
Outcast Racing
PNW Crew!!!
Afterhours Clan!!
Quote:
Originally Posted by aaron_ariens View Post
I think Henry just shit himself
Quote:
Originally Posted by Radness View Post
Its kind of like that carnival game "Whack A Mole" but with guns! Haha
Reply With Quote
  #8  
Old 07-11-2011, 05:12 AM
tootsie1 tootsie1 is offline
Learning to use the forums
 
Join Date: Jun 2011
Posts: 4
Default Re: Wipers gone south

I want to thank all that replied...I replaced the brake and stop relays (original ones (2) each showed a blade that had heavy discoloration ) located under the hood. no change. Thought I had checked every fuse availible-under the hood and the passenger side kick panel inside the cab. Took it in and was told a 10/20 amp fuse had to be replaced. Can't believe I missed them. All is well now.
Thanks, tootsie1.
__________________
06 Ranger/3.0/STD cab/Auto/2WD
Tootsie1
Reply With Quote
  #9  
Old 07-27-2011, 07:31 PM
Dawjr Dawjr is offline
Learning to use the forums
 
Join Date: Jul 2011
Posts: 13
Default Re: Wipers gone south

I've the same problem I changed wiper motor wiper switch relays fuses and the GEM did not help Went to ford to have them flash the GEM they said the computers would not talk that I must have a short or bad ground, The ground for the GEM is suppose to be under the relay/fuse box under the hood they say that it corrodes and may cause the problem
__________________
1999 Ranger 2x4 , 3.0 V6 , 5 spd, plain jane
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
wipers js250 Electrical Tech 2 10-06-2014 08:59 AM
Windshield Wipers Marine513 General Tech 3 06-29-2011 06:03 PM
wipers psycho dog Electrical Tech 5 03-31-2011 05:35 PM
Wipers not working babshas General Tech 0 11-14-2010 02:41 PM
no wipers...... NineD1XLT Electrical Tech 0 10-31-2010 12:42 PM