Ford Ranger Forum - Forums for Ford Ranger enthusiasts!

Go Back   Ford Ranger Forum - Forums for Ford Ranger enthusiasts! > >
Forgot Password? Join Us!

Welcome to Ford Ranger Forum

Reply
 
Thread Tools Search this Thread

  #1  
Old 10-11-2009, 02:39 PM
bultacco40 bultacco40 is offline
Learning to use the forums
 
Join Date: Oct 2009
Posts: 6
Default Hello everyone!

Hello all...I'm not sure where to post my question so I hope I'm doing this right. I have a 1994 Ford Ranger, 2.3L, 2wd. I've noticed lately that it's been running a lot cooler temperaturewise lately. It takes a while to warm up to about the "N" in Normal, then when the stat opens, it quickly goes down to a little above Cold. Top hose is warm bottom hose is almost cold.I do have some heat but not nice and hot. First thing I did was to change the t-stat. Same thing happens, I figured maybe I got a little RTV in there so I changed it again, same thing happens. The next week I changed the Water pump, radiator, rad cap, and hoses and both sending units, and fan clutch. Same thing happens, still runs cold. I then tied off the fan with some string to keep it from moving and it warmed up nicely and the heat was great. I let it warm up to about three quarters the way up the gauge before I untied the fan,cooled right back down to a little above the "C". Thanks for any advice!
Reply With Quote
  #2  
Old 10-11-2009, 02:57 PM
STL STL is offline
...............

 
Join Date: May 2009
Posts: 23,398
Default

Welcome

Have you looked at the heater core?
__________________
2005 Edge

Reply With Quote
  #3  
Old 10-11-2009, 03:23 PM
bultacco40 bultacco40 is offline
Learning to use the forums
 
Join Date: Oct 2009
Posts: 6
Default

Thanks for the responce. The heater core is about the only thing I've left out. Seeing that it does get good heat when it's hot and no signs of the core leaking, I just overlooked it. I plan on flushing the whole thing out, which I should have done while the pump and thermostat was out. I really didn't think the heater core would of had anything to do with my truck overcooling. But then again, that's why I'm here. I was begining to think it was just the gauge itself, but it seemed to work fine when I stopped the fan from turning. Thank you for the advice, I will look into that.
Reply With Quote
  #4  
Old 10-11-2009, 08:01 PM
mr.ranger mr.ranger is offline
Ford Ranger Driver
 
Join Date: Jul 2009
Posts: 652
Default

welcome
__________________
GOING TO BUY a 2009 ford ranger sport 4X4 ..currently saving up enough money
debating on the colour (red, blue or black?)
updating once i buy my baby
Reply With Quote
  #5  
Old 10-12-2009, 04:04 AM
mossyoak03 mossyoak03 is offline
hillbilly
 
Join Date: Sep 2009
Posts: 657
Send a message via AIM to mossyoak03
Default

welcome to FRF
__________________
Mud holes are like a pretty woman with an std, you want to hit but are scared of the consequences!

4wd is like a condom. i'd rather have it and not need it rather tan needing it and not having it!
Reply With Quote
  #6  
Old 10-12-2009, 03:08 PM
Trigger01 Trigger01 is offline
Ranger in Red
 
Join Date: Sep 2009
Posts: 245
Default

Howdy.
__________________
'08 F-350 FX4 Lariat CCSB
SOLD:04 Explorer 4x4 4.0
SOLD: 01 Ranger Edge 4 Door 4.0 Lifted on 33's
SOLD: 86 Ranger XL 2.0 4 cyl.
Reply With Quote
  #7  
Old 10-14-2009, 06:44 AM
Jay FX4 Jay FX4 is offline
▲▼▲▼▲▼▲▼
 
Join Date: Jun 2009
Posts: 2,511
Default

Welcome.
__________________
Quote:
Originally Posted by Ranger Dave (B25) View Post
Our foreign policy is laughable at best. As is the recipient of this years Cracker-Jacks prize for 'peace.'
Quote:
Originally Posted by Toms984x4 View Post
NOS for teh horse powaz!!!
ɹǝʌo ǝɯ dılɟ
Reply With Quote
  #8  
Old 11-09-2009, 10:30 PM
TerrenceStuart TerrenceStuart is offline
Old man driver.
 
Join Date: Nov 2009
Posts: 14,895
Default

welcome to FRF, Bultacco40!
__________________
some kind of vehicle.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search